Bug 160938 - Packages from Extras should be available from menu
Packages from Extras should be available from menu
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-18 19:53 EDT by Amadeus
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-03 16:19:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amadeus 2005-06-18 19:53:20 EDT
Description of problem:
Packages in Extras tend to be forgotten, because the user have no idea that they
excist.

Adding a repository line to /etc/yum.conf is hardly user friendly.

Suggested solution to problem:
In the package menu should programs like Abiword and Gnumeric still be present,
but with a small icon of a networking card to the left of the name.

The icon should indicate that, the installer will download these packages from
the net during installation.

In order not to prolong the installation time, these packages starts downloading
when the installation of the core packages begins. When these are installed, the
Extra packages will be done downloading, and be ready for installation.
Comment 1 Hubert Figuiere 2005-06-18 20:59:34 EDT
As one of the AbiWord maintainer, I really feel offended that Fedora has

a/ moved AbiWord and Gnumeric to extras
b/ made extras completely ignored because the package source is not by default.

(I already ranted about that in the past)
Comment 2 Paul Nasrat 2005-06-19 12:54:06 EDT
Users can do yum install abiword post install, adding yum support to anaconda
for FC5 is the plan.
Comment 3 Jacek Pliszka 2006-04-23 18:59:31 EDT
In addition to extras it would be great to have the option to include other
repositories.

E.g.  freshrpms - then users would be able to install xine(DVD player).
Comment 4 Chris Lumens 2006-08-03 16:19:09 EDT
There is now a UI and a kickstart method for adding additional repositories to
the install, and the packages in these extra repos are merged into the package
selection UI automatically.

Note You need to log in before you can comment on or make changes to this bug.