Bug 160939 - Describe problem, fix, or request for release notes
Describe problem, fix, or request for release notes
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: release-notes (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Release Notes Tracker
Tammy Fox
http://fedoraproject.org/wiki/DocsPro...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-18 20:02 EDT by James Hall
Modified: 2007-04-18 13:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-20 14:50:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Hall 2005-06-18 20:02:25 EDT
Description of problem, bug, incorrect information, or enhancement request:

At the part that explains how to file a bug report about the release notes, the
url does not wrap (on Firefox 1.0.4), causing alot of horizontal scrolling:

"For reporting errors or other requests about these release notes, file a bug
report using this pre-filled bugzilla template:

https://bugzilla.redhat.com/bugzilla/enter_bug.cgi?assigned_to=relnotes%40fedoraproject.org&blocked=151189&bug_file_loc=http%3A%2F%2Ffedoraproject.org%2Fwiki%2FDocsProject%2FReleaseNotes%2FProcess&bug_severity=normal&bug_status=NEW&cc=kwade%40redhat.com&comment=Description%20of%20problem%2C%20bug%2C%20incorrect%20information%2C%20or%20enhancement%20request%3A%0D%0A%0D%0A%0D%0AVersion%20of%20release%20notes%20this%20bug%20refers%20to%3A%0D%0A%0D%0AFedora%20Core%204%20final%20release&component=fedora-docs&contenttypeentry=&contenttypemethod=list&contenttypeselection=text%2Fplain&data=&dependson=&description=&estimated_time=0.0&estimated_time_presets=0.0&ext_bz_bug_id=&ext_bz_id=0&form_name=enter_bug&keywords=&maketemplate=Remember%20values%20as%20bookmarkable%20template&op_sys=Linux&priority=normal&product=Fedora%20Core&rep_platform=All&short_desc=Describe%20problem%2C%20fix%2C%20or%20request%20for%20release%20notes&version=devel&GoAheadAndLogIn=Login"
 

The above url needs to wrap or instead say :

For reporting errors or other requests about these release notes, file a bug
report using this <a href="linkhere">pre-filled bugzilla template</a>.

Version of release notes this bug refers to:

Fedora Core 4 final release
Comment 1 Paul W. Frields 2005-06-20 08:24:03 EDT
The release notes are written in DocBook XML and are rendered to HTML along with
other formats such as plain ASCII text.  The Fedora Documentation Project's
DocBook XML guidelines currently require use of the URL itself as the link text
for <ulink> (a DocBook counterpart of HTML <a>).  This is because some rendering
tools will not provide a proper hyperlink, and without one, a user wouldn't be
able to use the URL at all unless it was reproduced in full.  We do try to
provide TinyURLs where practical, but they usually appear in addition to the
full text of the link, which would not solve this problem.

Recommend this be CLOSED as NOTABUG.
Comment 2 Karsten Wade 2005-06-20 14:50:07 EDT
This was actually fixed in the release notes erratum:

http://fedora.redhat.com/docs/release-notes/fc4/errata/

Please help get these notes erratum out in the world.  Perhaps I should do an
announcement on f-announce-l.

Just the TinyURL was used.  This was done for the same reason this bug was
filed, because the URL does not wrap and is too long.  I decided the risk was
low of TinyURL purging the URL during the lifetime of these release notes. 
We'll follow the same policy in the future.

Paul's points are accurate.  With rare exception, we'll only use a TinyURL for
the pre-filled bugzilla template.

Thus was invented the new TINY-BUG-URL entity:

<!ENTITY TINY-BUG-URL "http://tinyurl.com/al5g4">


Note You need to log in before you can comment on or make changes to this bug.