Bug 160971 - plone alpha 2.1 put into extras instead of extras/testing
plone alpha 2.1 put into extras instead of extras/testing
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: plone (Show other bugs)
3
noarch Linux
medium Severity high
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
www.kube.homelinux.net
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-19 07:27 EDT by Keith Kube
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-01 08:39:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Keith Kube 2005-06-19 07:27:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
I believe that this is an alpha (testing) package.  Hence I beleive that this should be in http://download.fedora.redhat.com/pub/fedora/linux/extras/testing/3/i386/ instead of http://download.fedora.redhat.com/pub/fedora/linux/extras/3/i386/

because I have been running automated YUM updates, I've inadvertantly installed this alpha package of plone over the top of the stable 2.0.5.  

My plone sites have been down since 2.1 alpha was installed.

not all plone sites in the zope instance are crashing.  One plone site works, providing i am not using the ZMI to access it.  However, I think that this is an aside issue.

Version-Release number of selected component (if applicable):
plone-2.1-0.1.alpha2.fc3.noarch.rpm

How reproducible:
Sometimes

Steps to Reproduce:
1. install plone via yum - fc3 extras package
2. have yum install all updates
3. attempt to use plone website - www.kube.homelinux.net

Actual Results:  Site Error: AttributeError: typesToList (Also, an error occurred while attempting to render the standard error message.)


Expected Results:  In my opinion, plone-2.1-0.1.alpha2.fc3.noarch.rpm should be in the testing directory for FC3, not in the primary extras directory

Additional info:
Comment 1 Keith Kube 2005-06-19 07:51:50 EDT
Correction - all zope sites are crashing, the one site I thought wasn't was on
another machine.
Comment 2 Aurelien Bompard 2005-06-19 07:59:45 EDT
The problem is : Plone 2.0.x does not work with Zope 2.8, and Zope 2.8 has been
published into FC-3 (it should have waited for FC4, my mistake here). Only Plone
2.1 works with Zope 2.8
In addition, Plone 2.4 does not work with python 2.4 (shipped in FC4), so I have
to update it to 2.1 anyway.
Comment 3 Keith Kube 2005-06-19 08:20:14 EDT
(In reply to comment #2)
> The problem is : Plone 2.0.x does not work with Zope 2.8, and Zope 2.8 has been
> published into FC-3 (it should have waited for FC4, my mistake here). Only Plone
> 2.1 works with Zope 2.8
> In addition, Plone 2.4 does not work with python 2.4 (shipped in FC4), so I have
> to update it to 2.1 anyway.

Thanks for getting back to this so quick.
This still leaves me with all my plone sites being down (see
www.kube.homelinux.net for a detailed traceback).  Any suggestions on how to
move forward.  Do I try to rollback the plone instance, or try to solve the
problems?  
Comment 4 Aurelien Bompard 2005-06-19 11:47:17 EDT
I'd suggest to rollback both plone and zope for the moment. Sorry about that.

Note You need to log in before you can comment on or make changes to this bug.