Bug 160984 - Missing BuildRequires dependency on libattr-devel
Missing BuildRequires dependency on libattr-devel
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: usermode (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Bacovsky
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-19 09:38 EDT by Andreas Thienemann
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHBA-2007-0296
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 13:18:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Thienemann 2005-06-19 09:38:02 EDT
During a testbuild of usermode-1.74-1 in mock, the rebuild process stops
with the following error:

gcc -DXTHREADS -D_REENTRANT -DXUSE_MTSAFE_API -I/usr/include/libglade-2.0
-I/usr/include/gtk-2.0 -I/usr/include/libxml2 -I/usr
/lib64/gtk-2.0/include -I/usr/X11R6/include -I/usr/include/atk-1.0
-I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/in
clude/freetype2/config -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include  
-I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/i
nclude   -O2 -g -pipe -m64 -Wall -Wimplicit-int -Wimplicit-function-declaration
-Wuninitialized -Wunused -std=c99 -D_GNU_SOURC
E -DDATADIR=\"/usr/share\" -DGETTEXT_PACKAGE=\"usermode\" -O2 -g -pipe -m64
-Wall -Wimplicit-int -Wimplicit-function-declarati
on -Wuninitialized -Wunused -std=c99 -D_GNU_SOURCE   -o userinfo  userinfo.o
userdialogs.o userhelper-wrap.o reaper.o marshal.
o -Wl,--export-dynamic -lglade-2.0 -lgtk-x11-2.0 -lxml2 -lpthread -lz
-lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangoxft-
1.0 -lpangox-1.0 -lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0   
-lselinux -lattr  -lselinux -lattr
/usr/bin/ld: cannot find -lattr
collect2: ld returned 1 exit status
make[2]: *** [userinfo] Error 1
make[2]: Leaving directory `/builddir/build/BUILD/usermode-1.74'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/builddir/build/BUILD/usermode-1.74'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.71733 (%build)

Adding libattr-devel to the BuildRequires list should fix this problem.
Comment 1 Jindrich Novy 2005-06-21 09:46:07 EDT
libattr-devel dependency added, thanks.
Comment 2 Martin Bacovsky 2007-01-17 08:36:48 EST
This bug was fixed in times when we had no ack system. I need acks to add this
bugfix to errata which is already on QA. Since this is just BuildRequires fix,
QA is OK with that. 
Comment 3 RHEL Product and Program Management 2007-01-17 08:43:15 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 9 Red Hat Bugzilla 2007-05-01 13:18:46 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0296.html

Note You need to log in before you can comment on or make changes to this bug.