Bug 161011 - system-config-bind
system-config-bind
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-bind (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-19 14:55 EDT by Gustavo Marchetti
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-05 15:40:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error screen snapshots (121.83 KB, application/x-gzip)
2005-06-19 14:55 EDT, Gustavo Marchetti
no flags Details

  None (edit)
Description Gustavo Marchetti 2005-06-19 14:55:41 EDT
Description of problem:
Application error when try to save DNS configuration

Version-Release number of selected component (if applicable):
Fedora Core 4, system-config-bind-4.0.0-16_FC4 


How reproducible:
When attempt to insert a new connonical name (CNAME) record to an existing zone
and finish it clicking 'Save' button at main window.


Steps to Reproduce:
1. To run system-config-bind.
2. To select respective Internet Forwarding Zone.
3. Mouse right click, "Add..", "CNAME Alias"; at "CNAME Alias" window, inserting
'real.domainName.' at Domain Name text box, 'newCanonical.domainName.' at
Canonical Name text box.
4. 'Ok' button to confirm.
5. 'Save' at the main window to store new configuration.
  
Actual results:
After clicking Main Window 'Save' button, appears an Error window showing this
message:
"DNS Zone File Save Error
Save of Zone File /var/named/chroot/var/named/myZone.db Failed:
dns_master_load: /var/named/chroot/var/named/myzone.db:lineNumberX
real.domainName: CNAME and other data
zone myZone/IN: loading master file /var/named/chroot/var/named/myZone.db: CNAME
ans other data"


Expected results:
Correct saving of DNS data and restart of DNS Server service.

Additional info:
Original configuration files....

/var/named/chroot/var/named/carioca.homelinux.net:
[root@server named]# cat carioca.homelinux.net.db
$TTL 1H
@       SOA     server  root.server.carioca.homelinux.net. (    1
                                                3H
                                                1H
                                                1W
                                                1H )
        NS      server
server  IN      1H      A       192.168.254.1
speedstream     IN      1H      A       192.168.254.254
[root@server named]#




/var/named/chroot/var/named/carioca.homelinux.net.db.REJECT.2005-6-19_15.22.1
[root@server named]# cat carioca.homelinux.net.db.REJECT.2005-6-19_15.22.1
$TTL 1H
@       SOA     server  root.server.carioca.homelinux.net. (    1
                                                3H
                                                1H
                                                1W
                                                1H )
        NS      server
server  IN      1H      A       192.168.254.1
speedstream     IN      1H      A       192.168.254.254
        IN      1H      CNAME   router
[root@server named]#
Comment 1 Gustavo Marchetti 2005-06-19 14:55:41 EDT
Created attachment 115663 [details]
error screen snapshots
Comment 2 Jason Vas Dias 2005-07-05 15:40:55 EDT
Sorry for the delay in processing this bug report - I just got back
from vacation today.

This combination is actually an error:
"
speedstream     IN      1H      A       192.168.254.254
                IN      1H      CNAME   router
".

You cannot specify both an A or AAAA record for a DNS name AND a CNAME 
- it has to be one or the other.

The error message "CNAME and other data" comes from the
/sbin/named-checkzone program, and would in fact prevent your named 
process from resolving ANY names in that zone (SERVFAIL responses
would be returned for all names in carioca.homelinux.net. ).
The same effect that you desire could be achieved by:
"
speedstream     IN      1H      A       192.168.254.254
router          IN      1H      CNAME   speedstream
".
So the system-config-bind program is correctly preventing you from
saving a configuration that contains a fatal error, and this problem
is not a bug.

Note You need to log in before you can comment on or make changes to this bug.