Bug 161023 - Installation hangs when x.org attempts to load
Installation hangs when x.org attempts to load
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-19 19:02 EDT by Matt Merkey
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 22:29:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpm command output (47 bytes, text/plain)
2005-06-23 16:27 EDT, Matt Merkey
no flags Details
x.org configuration file (2.64 KB, text/plain)
2005-06-23 16:27 EDT, Matt Merkey
no flags Details

  None (edit)
Description Matt Merkey 2005-06-19 19:02:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
I'm trying to insall FC4 on my computer, but it keeps freezing the system solid at the point where x.org would start. I'm 99% certain the default radeon driver is at fault, as I had this same issue with FC3 after an update. I resolved it by installing ATI's linux drivers. ATI's drivers do no work with FC4, though. I've also had two other people report having identical problems with identical video hardware on a thread I started at linuxquestions.org.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Simply attempt to do a standard graphical installation.
  

Actual Results:  Solid system freeze where x.org would normally start.

Expected Results:  Installation should proceed as normal.

Additional info:

AMD XP 1900+
512 megs RAM
ATI Radeon 9600 Pro
Comment 1 Mike A. Harris 2005-06-22 17:36:53 EDT
Please hit enter at the end of each line when filing bug reports, as this
one is all on one line and unreadable.
Comment 2 Matt Merkey 2005-06-22 17:46:13 EDT
Here's the description again:

Description of problem:
I'm trying to insall FC4 on my computer, but it keeps freezing the system solid at
the point where x.org would start. I'm 99% certain the default radeon driver is at
fault, as I had this same issue with FC3 after an update. I resolved it by
installing ATI's linux drivers. ATI's drivers do no work with FC4, though. I've
also had two other people report having identical problems with identical video
hardware on a thread I started at linuxquestions.org.
Comment 3 Mike A. Harris 2005-06-23 15:15:22 EDT
Using the OS supplied drivers exclusively, please do the following:

- Run the following command:  rpm -V $(rpm -qa | grep "xorg-x11") > rpm.log
  and attach the rpm.log file.

- Attach your X server log file and config file to the bug report, as
  individual uncompressed file attachments.

Thanks in advance.

Comment 4 Matt Merkey 2005-06-23 16:26:18 EDT
It seems x.org is not getting to the point where it would start writing a log
file. I can't find anything resembling x.org log files in my /var/log directory.
Attached are the x.org conf file and the rpm command output.
Comment 5 Matt Merkey 2005-06-23 16:27:10 EDT
Created attachment 115902 [details]
rpm command output
Comment 6 Matt Merkey 2005-06-23 16:27:50 EDT
Created attachment 115903 [details]
x.org configuration file
Comment 7 Mike A. Harris 2005-06-23 17:43:39 EDT
You'll need to do a text mode installation, and after the OS is installed,
run "system-config-display --reconfig" to force X to be configured from
scratch.

After this, configure the system to start in runlevel 3, and run "startx".
Attach the X server log and config file from that session, so that we have
the proper files from a failing setup.
Comment 8 Matt Merkey 2005-06-23 18:20:13 EDT
A text mode installation is essentially what I did to get to the point I was at
in comment #4. I changed the default runlevel in my inittab to 3 and tried a
manual start of X using "startx". No log file was generated.

The "system-config-display" command locks my system up exactly the same as if I
was trying to do a graphical installation or was letting FC4 boot into runlevel
5. Basically the screen goes black and my system freezes solid (num and caps
lock lights don't cycle, ctrl-alt-del does nothing).
Comment 9 Matt Merkey 2005-06-23 18:27:08 EDT
I just got X to start by replacing "radeon" in the device section of my
xorg.conf with "vesa".
Comment 10 Mike A. Harris 2005-06-24 12:43:12 EDT
Using the "radeon" driver, please review bug #161242 and test the workaround
provided in that report.  Provide status update as to wether the issue still
occurs or not.  We haven't had anyone report the issue on Radeon yet, but
I'd like to be 100% sure wether there are problems on radeon caused by the
bad libvgahw also.

Thanks in advance.

Setting status to "NEEDINFO"
Comment 11 Matt Merkey 2005-06-25 16:54:24 EDT
I copied over my libvgahw.a file with the one provided in the link on that
report and then set my xorg.conf to use the radeon driver again. It didn't do
anything, I still have the exact same problem.
Comment 12 Olivier Baudron 2005-07-29 15:47:16 EDT
Can you try xorg-6.8.2-44 and tell me if it fixes your problem.
Comment 13 Matt Merkey 2005-08-14 15:42:52 EDT
Sorry for the slow response. I updated to xorg-6.8.2-45 from the development
tree. Exact same results.
Comment 14 Olivier Baudron 2005-09-01 15:48:42 EDT
Does it work better without DRI ?
Comment 15 Marta Diez 2005-10-04 11:49:53 EDT
Hi,i am really newbie in linux so i don´t know if i could help a lot. I have
the same problem, i install FC4 from DVD (test media ok), all seems to be ok
and when the packets are installed you have to reset the pc. At this moment
nothing happens after resseting, i have a black screen with a white cursor at
the left top.
I have tried to install FC4 several times, some in an empty hard disk and 
others updating red hat 8.0, always the same result. The graphic card is
recognized during the installation, even the graphic installation works ok but
i have always the black screen after reseting.
My PC is:
   AMD XP 1700+
   512 megs RAM
   ATI Radeon 7200
Regards.
Comment 16 Mike A. Harris 2005-10-05 22:29:49 EDT
Installations of Fedora Core 4 on i386 and x86_64 architecture with ATI
Radeon hardware work fine locally on multiple systems.  I am unable to
reproduce this problem at all.  The bug report does not contain sufficient
information to diagnose the problem further.

Recommendation:  Subscribe to xorg@lists.freedesktop.org mailing list, post
the problem and perhaps someone can help you to troubleshoot the issue down
to the root cause.  Once you have determined the root cause, file a bug report
in X.Org bugzilla at http://bugs.freedesktop.org and the problem should get
resolved in a future version of X.Org.

Setting status to "WORKSFORME"

Note You need to log in before you can comment on or make changes to this bug.