Bug 161076 - [RHEL-4] libwnck tasklist doesn't work well with xinerama
[RHEL-4] libwnck tasklist doesn't work well with xinerama
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: libwnck (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 160508 (view as bug list)
Depends On:
Blocks: 156322
  Show dependency treegraph
 
Reported: 2005-06-20 10:01 EDT by Ray Strode [halfline]
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHBA-2005-581
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 11:37:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ray Strode [halfline] 2005-06-20 10:01:17 EDT
+++ This bug was initially created as a clone of Bug #138874 +++

Description of problem: There is a problem with the window-list applet
on dual-head machines. The issue may be a xinerama bug in metacity,
not completely sure, but I think its in the applet itself. I have a
dual-head machine. On the left most monitor I have a menu panel with
some assorted other applets and icons. There is no problem with this.
On the second monitor, at the top of the screen I have a panel with
just one running applet, the window-list applet. This applet only
shows windows that are started on the monitor on which the panel with
the window-list applet resides. If I have an open window on the left
most monitor I will not see it in the window list until it has been
dragged onto the right most montitor. The problem works the same if I
have a panel with the window-list applet on the left monitor running
the applet. 


Version-Release number of selected component (if applicable):

2.8.1

How reproducible:
100% reproducible on a xinerama desktop

Steps to Reproduce:
1. create a panel on the right monitor
2. install the window-list applet
3. fire up an application on the left monitor
4. Watch as it doesn't appear in the applet
5. Drag the window to the screen that has the running window-list
applet and suddenly it appears. Move it back and ouila it disappears
again.
  
Actual results:
missing windows in the applet.

Expected results:
I expect this to work the way it did under FC2. 

Additional info:
Comment 2 Ray Strode [halfline] 2005-06-23 15:33:45 EDT
*** Bug 160508 has been marked as a duplicate of this bug. ***
Comment 4 Red Hat Bugzilla 2005-10-05 11:37:28 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-581.html

Note You need to log in before you can comment on or make changes to this bug.