Bug 161213 - ooffice segfaults when trying to open Help
ooffice segfaults when trying to open Help
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-21 10:20 EDT by Markku Kolkka
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-29 05:22:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
GDB backtrace (22.81 KB, text/plain)
2005-06-21 10:25 EDT, Markku Kolkka
no flags Details

  None (edit)
Description Markku Kolkka 2005-06-21 10:20:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fi-FI; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
When I try to access the Help function either with F1 or through the menu in any Openoffice.Org component a blank grey window is opened for a while, then the program crashes with a segmentation fault. "top" shows the soffice.bin process using all CPU and an increasing amount of memory before it crashes.

Version-Release number of selected component (if applicable):
openoffice.org-writer-1.9.104-2

How reproducible:
Always

Steps to Reproduce:
1. ooffice
2. Hit F1

  

Actual Results:  $ ooffice
/usr/lib/openoffice.org1.9.104/program/soffice: line 247:  5068 Segmentation fault      (core dumped) "$sd_prog/$sd_binary" "$@"


Expected Results:  Help display opens.

Additional info:

I'm not using nVidia or ATI binary X drivers or any other third-party drivers tainting the kernel.
Comment 1 Markku Kolkka 2005-06-21 10:25:58 EDT
Created attachment 115747 [details]
GDB backtrace

Just the beginning of the backtrace, it seems to continue to infinity repeating
a few lines.
Comment 2 Caolan McNamara 2005-06-29 05:22:33 EDT
should be ok in 1.9.112

Note You need to log in before you can comment on or make changes to this bug.