This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 161232 - KDE slows to unusable speed after hours of use
KDE slows to unusable speed after hours of use
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-21 12:03 EDT by Todd Gamblin
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-11 05:08:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Todd Gamblin 2005-06-21 12:03:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I'm using KDE on Fedora Core 4, with a 3Ghz IBM ThinkCentre tower computer and an NVidia GeForce 6800GT.  I've got the nvidia drivers installed, and I typically run a few konsoles, firefox, thunderbird, KDevelop, emacs, and sometimes gaim.  I've also got a Logitech mx500 mouse.  After a few hours (not predictable exactly how many, but no longer than a day, b/c this usually happens after I leave the machine on overnight) the system is slow to where it's unusable.  Scrolling in firefox with the scroll wheel is either slow or doesn't respond, and simple tasks in Thunderbird are slow or just don't respond.  Clicking on quick launch icons in the task bar often freezes with a little box around the clicked icon, and sometimes the application launches after a minute, sometimes it doesn't.  Starting any process takes forever, really -- I ran top, but had to wait a very long time for it to come up.  Here is the output I got:
top - 04:41:34 up 15:26,  5 users,  load average: 1.17, 0.37, 0.18
Tasks: 112 total,   3 running, 109 sleeping,   0 stopped,   0 zombie
Cpu(s):  0.2% us,  0.1% sy,  0.1% ni, 99.5% id,  0.1% wa,  0.0% hi,  0.0% si
Mem:   1034028k total,   725644k used,   308384k free,    52488k buffers
Swap:        0k total,        0k used,        0k free,   477132k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
 3473 root      16   0  278m  20m 4380 R 99.9  2.0   1:50.52 X
 3569 tgamblin  16   0 33060  15m  12m R 99.9  1.5   0:02.10 kwin
 3574 tgamblin  16   0 35252  17m  13m S 89.9  1.7   0:02.70 kicker
 3572 tgamblin  16   0 35376  17m  13m S 49.9  1.7   0:03.37 kdesktop
 3551 tgamblin  16   0 39108  15m  12m S 10.0  1.5   0:03.52 kded
 2857 root      16   0  2744  652  564 S  5.0  0.1   0:00.46 nifd
 3895 tgamblin  16   0 36908  17m  13m S  5.0  1.7   0:00.91 konsole
 6666 tgamblin  16   0  5284 2444 1624 R  5.0  0.2   0:00.03 top
    1 root      16   0  1748  572  492 S  0.0  0.1   0:01.00 init
    2 root      RT   0     0    0    0 S  0.0  0.0   0:00.00 migration/0
    3 root      34  19     0    0    0 S  0.0  0.0   0:00.00 ksoftirqd/0
    4 root      RT   0     0    0    0 S  0.0  0.0   0:00.00 watchdog/0
    5 root      RT   0     0    0    0 S  0.0  0.0   0:00.00 migration/1
    6 root      34  19     0    0    0 S  0.0  0.0   0:00.00 ksoftirqd/1
    7 root      RT   0     0    0    0 S  0.0  0.0   0:00.00 watchdog/1
    8 root      10  -5     0    0    0 S  0.0  0.0   0:00.06 events/0
    9 root      10  -5     0    0    0 S  0.0  0.0   0:00.00 events/1
   10 root      10  -5     0    0    0 S  0.0  0.0   0:00.00 khelper
   11 root      10  -5     0    0    0 S  0.0  0.0   0:00.00 kthread
   14 root      20  -5     0    0    0 S  0.0  0.0   0:00.00 kacpid

Or at least, that's the top of top.  I've also seen this where thunderbird-bin was taking up 99.9 %CPU.  

I'm using the vmlinuz-2.6.11-1.1369_FC4smp kernel.

This happens every time I use my computer, and I end up having to reset it manually.  This usually involves the power switch, as ctrl-alt-delete is not responsive.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Turn on machine, startx
2. start 2 terminals, kde 3.4.1, kdevelop 3.2.1, firefox (latest), and thunderbird (latest).  Maybe start a few instances of emacs and gaim, but not required.
3. wait.

Actual Results:  computer became unusable, unresponsive.  CPU time of X, kicker, kdesktop, kicker, and kded shot up.

Expected Results:  computer remains operational for a very long time.  

Additional info:
Comment 1 Ngo Than 2005-06-21 12:14:24 EDT
could you please try to use nv driver from xorg-x11. Does this problem still
appear. Thanks

I have kde 3.4.1 running since 1 week without to have this problem!
Comment 2 Todd Gamblin 2005-06-21 12:42:14 EDT
Ok, I'm trying this with the NV Driver, and it seems good so far.  I will update
this if it does not freeze after a day.  

Does the nv driver support openGL?  I cannot seem to get it to work.  Also, it
seems like I was using this driver with KDE when I first started with FC4, and
the selection box created when you drag on the desktop was translucent.  Now
that I have switched back, it is not.  What's wrong w/my configuration?
Comment 3 Ngo Than 2005-06-21 12:52:47 EDT
no, the driver does not support openGL. Please disable openGL feature in your
KDE settings.
Comment 4 peter hudak 2005-10-11 02:47:38 EDT
Hi all,

I have a similar problem with the same machine, however I'm running it as a
server, no X windows or whatsever.
The problem is that the machine stops responding after approx. 6 hours of
running. It seems like it is unable to read/write from/to the disks, load is
1.07 or more at the time. what is really strange is, that the machine has been
running for 2 days (I did not lose my ssh connection to it) but uptime shows
only 15 hours.
I thought it had something to do with ACPI/APM, SATA driver or MD. so I played
around, installed the 2.6.13 kernel and tired to disable acpi, raid... upgraded
the machine bios to the latest of course... but the usage/not usage of apm/acpi,
raid or plain disks (ext3) does not seem to affect the machine in any way. I
disabled all powersaving in bios too. the result is still the same.
after 5-6 hours the machine stops responding when trying to access disks.
but there is absolutely no error/warning/whatever in dmesg.

any ideas?
Comment 5 Ngo Than 2005-10-11 05:08:26 EDT
Peter, it's not the same problem and seems a kernel problem to me. You should
fill this bug to the component kernel please. Thanks

Note You need to log in before you can comment on or make changes to this bug.