Bug 161243 - cannot add records in jpilot, crashes
cannot add records in jpilot, crashes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: jpilot (Show other bugs)
4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Ivana Varekova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-21 13:36 EDT by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-01 02:49:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2005-06-21 13:36:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I started jpilot on a clean .jpilot directory.  When I tried to add a record, I get the following messages:

  pc_read_next_rec(): Out of memory

I also get these messages in my terminal:

(jpilot:3913): Gtk-CRITICAL **: gtk_check_menu_item_set_active: assertion `GTK_IS_CHECK_MENU_ITEM (check_menu_item)' failed

Finally, when I exit it gives a seg fault.

Also, when I ran it on my old .jpilot directory (from FC3) it seems to ignore all my .pdb files and created a bunch of .pc3 files.  Or maybe it just couldn't read them for some reason.  I don't know.

Version-Release number of selected component (if applicable):
jpilot-0.99.8-0.pre8.4

How reproducible:
Always

Steps to Reproduce:
Just run jpilot (on any empty .jpilot directory or not) and try to add new records.

It makes this version of jpilot completely useless for FC4.

Additional info:
Comment 1 Ivana Varekova 2005-06-22 02:32:54 EDT
Please update your jpilot and pilot-link packages. There are new fc4 versions -
jpilot-0.99.8-0.pre9.fc4.1 and pilot-link-0.12.0-0.pre3.0.fc4.1. This should fix
your problem. 
Please write a comment whether is your problem fixed. 
Ivana Varekova
Comment 2 Need Real Name 2005-06-22 12:47:44 EDT
Okay, it seems that it is fixed now after I synced my pilot with an empty
.jpilot directory.  It wouldn't read my old .jpilot directory, however.
Comment 3 Ivana Varekova 2005-06-23 08:11:38 EDT
There was problem with pilot-link-0.12.0-0.pre2 sync. pilot-link-0.12.0-0.pre3 
should fix this problem (this version need new jpilot-0.99.8-0.pre9). 
Comment 5 Ivana Varekova 2005-07-01 02:49:20 EDT
pilot-link-0.12.0-0.pre3 and jpilot-0.99.8-0.pre9 fix problem.

Note You need to log in before you can comment on or make changes to this bug.