Bug 161267 - platform complains when jdt, pde, and rcp arent installed
platform complains when jdt, pde, and rcp arent installed
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-21 17:52 EDT by Michael Favia
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 3.1.1-1jpp_1fc.FC4.11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-04 14:21:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Favia 2005-06-21 17:52:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
When installing just the base platform without jdt and pde eclipse complains when you are trying to install plugins (subclipse, and phpeclipse to be specific) and in some cases prevents their installation (if you havent installed jdt/ecj) because of an "improperly configured product". This bug is file by request of overholt.

Version-Release number of selected component (if applicable):
3.1 RC3

How reproducible:
Didn't try

Steps to Reproduce:
install:
eclipse-platform-3.1.0_fc-0.RC3.1
and
libswt3-gtk2-3.1.0_fc-0.RC3.1
tomcat5-jasper-5.0.30-5jpp_6fc
tomcat5-servlet-2.4-api-5.0.30-5jpp_6fc
tomcat5-5.0.30-5jpp_6fc
to satisify deps

Run eclipse and go under:
Help > updates > manage config
under:
Eclipse SDK > /usr/share/eclipse > eclipse project > Show properties > status
this is the message:
Included feature "org.eclipse.platform.source_3.1.0" is missing.

Included feature "Eclipse Java Development Tools" version "3.1.0" is disabled.

Included feature "org.eclipse.jdt.source_3.1.0" is missing.

Included feature "org.eclipse.pde_3.1.0" is missing.

Included feature "org.eclipse.pde.source_3.1.0" is missing.





Actual Results:  Unable to update and manage config complains about improper config.

Expected Results:  Platform shoul operate normally with or without "defualt plugins" so that it can be used for other development environments.

Additional info:
Comment 1 Michael Favia 2005-06-23 15:41:16 EDT
Well after a bit more invesitgation i am able to say that it is indeed
reproducible. I have attempted without success to configure eclipse-platform
with libswt3-gtk2 and everytime i get the same roadbloack to adding plugins and
otherwise manage updates. My temporary workaround options are:

1. install all the cruft (pde, jdt, ecj, etc) that i dont need.
2. manually install the plugins and feature sets.

I have opted for the later one in the short term but have had limited success
with full functionality. I'm going to try and see why platform thinks the others
should be there.
Comment 2 Andrew Overholt 2005-06-24 16:22:25 EDT
Can you try with the 3.1 RC3 RPMs I just built into rawhide when they get synced
publicly tomorrow sometime?  I'm confused as to what is causing this.  There are
some dot-files that I guess could be causing it.  I'll try to investigate myself.
Comment 3 Andrew Overholt 2005-06-24 16:40:52 EDT
It looks like platform has a requirement on rcp.  When I install rcp, I can
install subclipse no problem.  I'll rebuild in rawhide with a requirement on rcp
for platform.
Comment 4 Michael Favia 2005-07-07 14:48:36 EDT
UPDATE: Removed all deps and started over. Grabbed eclispe-platfom from
development branch to see what deps are required and installed as many as
possible from fc4 yum chan (tomcat5, lucene, etc) before turning enabling yum
rawhide. yum installed eclispe-platform it dragged along the following:
Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 eclipse-platform        i386       1:3.1.0_fc-2     development        41 M
Installing for dependencies:
 eclipse-rcp             i386       1:3.1.0_fc-2     development       123 k
Updating for dependencies:
 cpp                     i386       4.0.0-13         development       2.1 M
 gcc                     i386       4.0.0-13         development       2.8 M
 gcc-c++                 i386       4.0.0-13         development       2.7 M
 gcc-gfortran            i386       4.0.0-13         development       2.3 M
 gcc-java                i386       4.0.0-13         development       2.3 M
 libgcc                  i386       4.0.0-13         development        46 k
 libgcj                  i386       4.0.0-13         development       7.6 M
 libgcj-devel            i386       4.0.0-13         development       1.0 M
 libgfortran             i386       4.0.0-13         development       133 k
 libstdc++               i386       4.0.0-13         development       300 k
 libstdc++-devel         i386       4.0.0-13         development       9.0 M
 libswt3-gtk2            i386       1:3.1.0_fc-2     development       5.3 M

Proceeded with install. Started up eclipse and it runs great. The phpeclipse
plugins were already installed when i first got in but i might have left them in
plugins last time. I do have issues when running "HELP > SOFTWARE UPDATES > FIND
AND INSTALL..." i get an error message concerning the features.xml file for rcp.
Everything seems to work well but if you look under  "HELP > SOFTWARE UPDATES >
MANAGE" you will see that eclipse is still looking for pde, jdt, and
platfrom-source and complaining that they arent there. I am going to wipe the
slate clean and try once more to install the platform from these rpms and
install the phpeclipse plugins with svn to see if issues are still outstanding.
Comment 5 Andrew Overholt 2005-12-05 16:50:09 EST
While investigating this and bug 173589, I determined that
eclipse-platform-devel needs eclipse-rcp-devel.  I've added this and it will
show up in rawhide and fc4-updates-testing soon.
Comment 6 Andrew Overholt 2005-12-08 10:22:59 EST
I've built packages for both rawhide (eclipse-3.1.1-1jpp_9fc) and FC4
(eclipse-3.1.1-1jpp_1fc.FC4.8 ... will appear in updates-testing at some point
today) that contain this fix.  When you get a chance, please test these to see
if they fix this problem.  Thanks.
Comment 7 Ben Konrath 2006-01-04 14:19:39 EST
Confirming this is fixed in updates-testing with the following package versions:

gcc-4.0.2-8.fc4
eclipse-platform-3.1.1-1jpp_1fc.FC4.11

Note You need to log in before you can comment on or make changes to this bug.