Bug 161380 - HS20 8832 blade needs acpi=noirq to install
HS20 8832 blade needs acpi=noirq to install
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-22 15:01 EDT by Robert de Rooy
Modified: 2015-01-04 17:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 18:43:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bootlog of HS20 8832 blade with IDE RAID (MegaIDE) enabled, when not passing noirq (7.28 KB, text/plain)
2005-06-22 15:01 EDT, Robert de Rooy
no flags Details

  None (edit)
Description Robert de Rooy 2005-06-22 15:01:09 EDT
Description of problem:

When booting FC4 i386 on the IBM HS20 8832 blade, the machine hang when starting
Anaconda.

the last line printed on the console is 'running /sbin/loader'. You see a flash
where the display goes black and comes back and that is it.

ALT key sequences to switch VT have no effect

booting with acpi=noirq allows the installation to succeed

Version-Release number of selected component (if applicable):

FC4

How reproducible:

every time, unless acpi=noirq or acpi=off is specified

Steps to Reproduce:
1. attempt to install HS20 8832 blade with FC4
2.
3. 
  
Actual results:

hang when starting anaconda, unless acpi=noirq is specified

Expected results:

acpi=noirq should not be needed

Additional info:

This is the IBM HS20 blade with dual Intel Xeon x86 processors.

It has optional support for IDE-RAID (LSI MegaIDE) which can be enabled/disabled
in the BIOS.
With RAID disabled, the disks look like regular IDE drives.
The problem is the same with IDE-RAID enabled or disabled, when acpi=noirq is
not passed, although when it is enabled the kernel boots very slowly with lots
of 'lost interrupt' messages from the IDE drives.

With acpi=noirq the install works for both the non-raid and the raid mode
(dmraid works).
Comment 1 Robert de Rooy 2005-06-22 15:01:10 EDT
Created attachment 115829 [details]
bootlog of HS20 8832 blade with IDE RAID (MegaIDE) enabled, when not passing noirq
Comment 2 Dave Jones 2005-07-15 17:50:57 EDT
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.
Comment 3 Robert de Rooy 2005-07-28 23:00:24 EDT
I installed the updated 2.6.12-1.1398_FC4 i686 SMP kernel, and removed
acpi=noirq from grub.conf and rebooted.

The system came back up without any problems, so this issue can be closed.

Note You need to log in before you can comment on or make changes to this bug.