Bug 16143 - Upgrade from RH6.2 causes runtime error in progress_gui.py
Upgrade from RH6.2 causes runtime error in progress_gui.py
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i586 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-13 22:14 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-14 16:54:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-08-13 22:14:50 EDT
After selecting which packages to install from a custom upgrade, anaconda
crashes just after verifying dependencies.  Here is text from the bug
report: (I can send you a description of my hardware if requested)

<-- BEGIN SNIP -->
Traceback (innermost last):
  File "/usr/bin/anaconda", line 426, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/gui.py", line 332, in run
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/gui.py", line 674, in run
  File "/var/tmp/gnome-python-root/usr/lib/python1.5/site-packages/gtk.py",
line 2554, in mainloop
  File "/var/tmp/gnome-python-root/usr/lib/python1.5/site-packages/gtk.py",
line 125, in __call__
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/gui.py", line 424, in
nextClicked
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/gui.py", line 462, in
setScreen
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/iw/progress_gui.py", line
154, in getScreen
AttributeError: glob

Local variables in innermost frame:
self: <progress_gui.InstallProgressWindow instance at 84e3610>
glob: <module 'glob' from '/usr/lib/python1.5/glob.py'>

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<-- END SNIP -->
Comment 1 Michael Fulbright 2000-08-14 16:54:48 EDT
We've done several of these upgrades and have not had any problems.  If you
burned an ISO image please
try again, this appears to be caused by a bad CD image.

Note You need to log in before you can comment on or make changes to this bug.