Bug 161430 - internal compiler error: Segmentation fault
Summary: internal compiler error: Segmentation fault
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc4 (Show other bugs)
(Show other bugs)
Version: 4
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL: http://netlib.org/ode/rksuite/rksuite.f
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-23 12:28 UTC by Jochen Küpper
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 4.0.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-10 20:43:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jochen Küpper 2005-06-23 12:28:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax)

Description of problem:
Trying to compile the file rksuite.f (http://netlib.org/ode/rksuite/rksuite.f) I get the following compiler message:

> gfortran -c rksuite.f

rksuite.f: In function 'setup':
rksuite.f:210: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.


Version-Release number of selected component (if applicable):
gcc-4.0.0-8

How reproducible:
Always

Steps to Reproduce:
1. Download http://netlib.org/ode/rksuite/rksuite.f
2. Run gfortran -c rksuite.f


Actual Results:  rksuite.f: In function 'setup':
rksuite.f:210: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.

Expected Results:  rksuite.o should be created

Additional info:

Comment 1 Jakub Jelinek 2005-07-07 15:44:20 UTC
Seems to be fixed on HEAD by
http://gcc.gnu.org/ml/gcc-patches/2005-07/msg00425.html


Comment 2 Jakub Jelinek 2005-07-10 20:43:07 UTC
Should be fixed in gcc-4.0.1-1 in rawhide.


Note You need to log in before you can comment on or make changes to this bug.