Bug 161542 - Colors messed up with video players
Colors messed up with video players
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-24 00:52 EDT by William Lovaton
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-26 20:00:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
This is my log file (41.61 KB, text/plain)
2005-06-26 20:08 EDT, William Lovaton
no flags Details
This is my config file (2.81 KB, text/plain)
2005-06-26 20:13 EDT, William Lovaton
no flags Details

  None (edit)
Description William Lovaton 2005-06-24 00:52:56 EDT
Description of problem:
I upgraded a few days ago from FC3 to FC4 and so far it has been a good distro.
But I have some problems with video files (ogg files and realplayer).  All those
videos look with very bad colors, kind of black/white, but not. :-)  The color
of the videos are completely messed up.

I tried the videos with totem (gstreamer): the video looks bad and the sound is
worse (ogg files).

Tried with HelixPlayer: video still the same but sound is good (ogg files).

The same with realplayer: video looks bad, sound is good (.rm .ram files).

Just for the record, the videos I have are the ones from GUADEC conference in
stuttgart.  I played them with FC3 and the colors were good, the sound was good
but the reproduction was problematic, it skipped some frames (which still
happens in FC4 and Ubuntu hoary).

I'm not sure if xorg is the culprit but like you can see gstreamer doesn't seem
to be the problem.  I havent updated to latest xorg in the updates repository,
I'll do it tomorrow night and will update the bug report.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-31

How reproducible:
Always

Steps to Reproduce:
1. Play a video file
2.
3.
Comment 1 Mike A. Harris 2005-06-24 12:39:15 EDT
Upgrade to the current erratum, and if the problem persists, attach your
X server log and config file (always do that for X bug reports) as individual
uncompressed file attachements.

Also, please review bug #161242 and test the workaround present in that
bug report and provide feedback here.  If the test does not change anything,
revert the module back to the original module.

Setting status to "NEEDINFO"
Comment 2 William Lovaton 2005-06-26 20:00:55 EDT
Well, I made a clean install from FC3 to FC4.  I backed up my .gconf directory
to keep my settings (specially for evolution) and then restored it back after
installation.  I deleted that directory and started a fresh configuration...
that solved the problem, the colors are good now in every video player, even the
sound problem I mentioned in the report is fixed now.  Probably there was a
problem with my old setting in the new system.

The only thing that remains is a problem playing the videos from GUADEC 6. 
Those ogg files seem to be screwed, specially if I play them with a gstreamer
based player, the video is erratic, with fast motion and then normal motion, and
the video gets blocked very often until your move the slide button front and
back. basically they are unviewable.  I had problems with them in FC3 (xine),
Ubuntu and FC4 (GST).  The only player who seems to play them right is the Helix
Payer but there are some videos where the image and the sound is out of synch
for about 2 minutes or more, gstreamer seems to keep the sync though.

I'll report the gstreamer problems upstream.

For the record, the libvgahw library doesnt seem to affect me.  I am using an
nVidia GForce2 MX.  I'll close this bug report and just in case, I'll attach my
X log file and my xorg.conf file later.

Thanx,

-William
Comment 3 William Lovaton 2005-06-26 20:08:30 EDT
Created attachment 115999 [details]
This is my log file
Comment 4 William Lovaton 2005-06-26 20:13:36 EDT
Created attachment 116000 [details]
This is my config file

Right now I am using the nv drivers, later on I will be switching to the
propietary nVidia drivers.

Note You need to log in before you can comment on or make changes to this bug.