Bug 161624 - As built, gd requires glibc > 2.3.3
As built, gd requires glibc > 2.3.3
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gd (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-24 17:21 EDT by Jeff Spirko
Modified: 2015-03-04 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-27 05:39:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Spirko 2005-06-24 17:21:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Description of problem:
With glibc 2.3.3, programs using this version of the gd library will not link because of a missing __sprintf_chk, etc. symbols.  These symbols are present in glibc 2.3.5.  This affects people who try to upgrade to this version of gd while not doing a full upgrade of their system to fc4.


Version-Release number of selected component (if applicable):
gd-2.0.33

How reproducible:
Always

Steps to Reproduce:
1. Downgrade to glibc-2.3.3
2. Create a simple test program that uses gd, called gdtst.c:
char gdImageCreate ();
int main () {
  gdImageCreate ();
  return 0;
}
3. Compile the program (edit for location of libX11.so):
  gcc -L[location of libX11.so] -o gdtst gdtst.c -lgd -lXpm -lX11
  

Actual Results:  gcc failed to produce the executable.

Additional info:

This version of the gd library appears to work with X11R6; i.e. it may not require xorg, even though it is labeled as such.
Comment 1 Phil Knirsch 2005-06-27 05:39:41 EDT
Such partial updates can often lead to such problems and it's not a gd specific
problem.

Unfortunately there are only 3 possible ways out of this:

1) Update gd with yum and pull in all required dependant updates as well
2) Don't update gd
3) Rebuild the FC4 srpm on the FC3 system and install that.

Read ya, Phil
Comment 2 Jeff Spirko 2005-06-27 14:49:33 EDT
I was doing (1).  My point was that gd-2.0.33-2 isn't marked as requiring an
update of glibc from 2.3.3 to 2.3.5, though it should be.

After manually updating to glibc-2.3.5-10, gd now works fine.

Note You need to log in before you can comment on or make changes to this bug.