Bug 161762 - xorg don't uses hw accel when run glx software with ATI Radeon
xorg don't uses hw accel when run glx software with ATI Radeon
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-26 22:43 EDT by Hernan Petitti
Modified: 2013-03-13 02:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-20 15:13:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hernan Petitti 2005-06-26 22:43:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Red Hat/1.0.4-1.4.1 Firefox/1.0.4

Description of problem:
when I run glxgears the rendering is very slow and the process takes a lot of cpu charge (100%)
The video card is
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M6 LY
on HP pavilion ze5165

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-1.EL.13.6

How reproducible:
Always

Steps to Reproduce:
1.start gnome session
2.run glxgears or other glx software
3.
  

Actual Results:  glxgears renders at 90.000 fps and uses 100% cpu

Expected Results:  glxgears renders at 200.000 or more fps like FC3

Additional info:

lspci
...
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M6 LY
...

/etc/X11/xorg.conf
...
Section "Device"
        Identifier  "Videocard0"
        Driver      "radeon"
        VendorName  "Videocard vendor"
        BoardName   "ATI Radeon Mobility M6"
# it's the same with or without this options
#       Option      "RenderAccel" "on"
#       Option      "BusType" "AGP"
#       Option      "AGPMode" "4"
#       Option      "AGPFastWrite" "on"
#       Option      "DynamicClocks" "on"
EndSection
Comment 1 Hernan Petitti 2005-06-27 21:56:14 EDT
/etc/X11/xorg.conf
...
Section "Module"
        Load  "dbe"
        Load  "extmod"
        Load  "fbdevhw"
        Load  "glx"
        Load  "record"
        Load  "freetype"
        Load  "type1"
        Load  "dri"
EndSection
...
Comment 3 Mike A. Harris 2005-07-01 03:10:28 EDT
DRI support for Radeon is disabled by default in RHEL4 due to reported
instabilities of DRI with various Radeon chipsets.

For the time being, you must manually enable DRI by hand editing the config
file and adding to the Device section:

    Option "dri"


Official Red Hat support for this issue may be obtained by submitting
an official support request at http://www.redhat.com/apps/support or by
telephone at 1-888-RED-HAT1.

Comment 4 Mike A. Harris 2005-09-20 15:13:50 EDT
DRI was disabled by default on all Radeon hardware in RHEL4 due to
stability issues.  Users were able to manually override the default
however via reconfiguration, with the caveat that instability was
possible.

The latest updates for RHEL4 re-enable DRI by default on all Radeon
hardware except Radeon 7000.

Closing bug as fixed in the current errata release.

Note You need to log in before you can comment on or make changes to this bug.