Bug 161765 - Main menus (Applications/Places/Desktop) not keyboard-accessible using letter keys
Main menus (Applications/Places/Desktop) not keyboard-accessible using letter...
Status: CLOSED DUPLICATE of bug 152259
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-27 00:47 EDT by Jeff Walden (remove +brc to email)
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-27 12:38:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Walden (remove +brc to email) 2005-06-27 00:47:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050625 Firefox/1.0+

Description of problem:
The main Applications menu can be accessed in FC4's default config by hitting Alt+F1.  From here one would expect hitting "A" would select and activate the Accessories menu, "O" the Office menu, etc.  However, in Fedora Core 4 letter keys do not activate the appropriate item -- they seem to do nothing whatsoever.

This problem also occurs when menu items are focused, not just when the "Applications" part of the UI is focused.  For example, if you have Calculator (in Accessories) focused and you hit "T", the expected response is that Text Editor is opened.  The real response is nothing -- focus stays on Calculator and no new applications are opened.

Version-Release number of selected component (if applicable):
gnome-panel-2.10.1-10

How reproducible:
Always

Steps to Reproduce:
Part 1, in a default FC4 installation:
1. Hit Alt+F1 to open the Applications menu.
2. Hit "A" to trigger the Accessories submenu -- the result should be that Accessories is opened and focus is moved inside the menu, but instead nothing happens.

Part 2, in a default FC4 installation:
1. Hit Alt+F1 to open the Applications menu.
2. Arrow down to Accessories, move focus into it, and focus the Calculator item.
3. Hit "T" to trigger the Text Editor and the menu's closing -- the result should be that Text Editor is opened, but instead nothing happens.

Additional info:

I'm unsure whether or not the latter part (letter keys not working within the menus) is a separate bug from the former part (letter keys not working when the Applications menu widget itself has focus).  In FC3 selecting menus with letter keys after pressing Alt+F1 did not work, but when the menu itself had focus the letter keys worked at activating submenus and menu items.  The workaround for the selection problem was to simply use an alternate menu (whose name I've forgotten) from the Add to Panel dialog that did fully support keyboard access, so I never reported a bug.

I marked this with a Normal severity because it makes keyboard navigation of the menus much more difficult, and there's no easy workaround for long menus if you want to select an item right in the middle of the list (e.g., "Keyring Manager" within the System Tools menu underneath Applications or "Logical Volume Management" within the System Settings menu underneath Desktop).
Comment 1 Mark McLoughlin 2005-06-27 12:38:25 EDT

*** This bug has been marked as a duplicate of 152259 ***

Note You need to log in before you can comment on or make changes to this bug.