Bug 161790 - Serial console not working
Serial console not working
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: grub (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2005-06-27 09:01 EDT by Bastien Nocera
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-05-02 09:20:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2005-06-27 09:01:16 EDT
With grub-0.95-3.1, the Serial console does not work properly.

Using this grub.conf gives different behaviour on RHEL3 and RHEL4:
serial --unit=0 --speed=9600
terminal --timeout=5 serial console
password --md5 $1$6OscskD3$fUuBZ5w4AFtyFZmpThLNF.
title Red Hat Enterprise Linux AS (2.6.9-5.ELsmp)
       root (hd0,0)
       kernel /vmlinuz-2.6.9-5.ELsmp ro root=/dev/system/root console=ttyS0,9600
rhgb quiet selinux=0
       initrd /initrd-2.6.9-5.ELsmp.img

On RHEL3, this gives us a 5 second timeout to hit a key on either the console or
the serial terminal, and whichever we hit the key on then becomes the
controlling console. If no key is hit, after a 5 second time out, the terminal
becomes the controlling console.

On RHEL4 however, the serial terminal effectively goes dead and after the 5
second timeout on the console, that becomes unresponsive too. The only way to
actually cause grub to load is to hit a key on the console during the 5 second
timeout - the console then becomes the controlling console and grub displays.
Comment 7 Stephan Dühr 2005-09-16 13:04:02 EDT
With RHEL3 u5 on a Sun v20z I found the same problem than described above for
RHEL4: I can't find a way to reboot the system without keyboard interaction on
the serial console. I'm kickstarting the system off a Satellite Server. For
"Extra Kernel Parameters" in the Kickstart Profile Options I use
serial=0,9600n8 console=ttyS0 console=tty0 nofb

In the append line of the pxe config file, i only use
nofb serial=0,9600n8 console=ttyS0
because if I add console=tty0, there only appears "AT" on the serial console
when the install starts and the progress is invisible.

Now I found out, that I see the grub menu, if i comment out the following two
lines from /boot/grub/grub.conf:
#serial --unit=0 --speed=9600
#terminal --timeout=10 serial console
This seems to work because the BIOS of the v20z is already set up to send its
output to the serial port.

Next I tried kickstarting the system but this time with empty "Extra Kernel
Parameters" in the Kickstart Profile Options. I left the append in the PXE
config file so that I can see the progress of the install. When Kickstart
finished, it reboots the system and with some luck I can see "any k" or just
nothing meaningful. Without keyboard interaction, it does not boot. The two
lines mentioned above (serial, terminal) still appear in the generated
grub.conf. As a workaround, I use the following script in postinstall to
deactivate the serial and terminal line:

sed -e 's/^serial/#serial/; s/^terminal/#terminal/' \
     < /boot/grub/grub.conf > /tmp/grub.tmp
mv -f /tmp/grub.tmp /boot/grub/grub.conf

This works. The System is now able to reboot unattended.
What I consider as a Bug is that grub waits for a key to be pressed. After the
specified timeout it should boot in any case. The generated serial and terminal
lines make sense if the BIOS does not support serial redirection, but only if
unattended boot works.
Comment 15 Issue Tracker 2007-06-19 04:31:49 EDT
ticket closed

Internal Status set to 'Resolved'
Status set to: Closed by Client
Resolution set to: 'Rejected'

This event sent from IssueTracker by uthomas 
 issue 77240

Note You need to log in before you can comment on or make changes to this bug.