Bug 161828 - mock.py references mach-helper
mock.py references mach-helper
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
4
All Linux
medium Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-27 12:21 EDT by Ralf Corsepius
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-29 01:14:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2005-06-27 12:21:46 EDT
Description of problem:

Some defaults being used internal of mock.py refer to mach-helper:

Near mock.py:595
    config_opts['basedir'] = '/var/lib/mach/roots/' # root name is automatically
added to this
    config_opts['chroot'] = '/usr/sbin/mach-helper chroot'
    config_opts['mount'] = '/usr/sbin/mach-helper mount'
    config_opts['umount'] = '/usr/sbin/mach-helper umount'
    config_opts['rm'] = '/usr/sbin/mach-helper rm'
    config_opts['mknod'] = '/usr/sbin/mach-helper mknod'
    config_opts['yum'] = '/usr/sbin/mach-helper yum'
    config_opts['runuser'] = '/sbin/runuser'

Version-Release number of selected component (if applicable):
mock-0.3-2.fc4

Additional info:
This doesn't have any effects, unless using custom configurations, because the
standard *.cfgs as being shipped with the mock-rpm override these settings.
Comment 1 Seth Vidal 2006-03-29 01:14:29 EST
fairly sure this is fixed now.

Note You need to log in before you can comment on or make changes to this bug.