This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 161882 - mailutil segfaults when converting some mbx mailboxes
mailutil segfaults when converting some mbx mailboxes
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: imap (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-27 23:01 EDT by Josh Kelley
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 14:59:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Josh Kelley 2005-06-27 23:01:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
Mailutil segfaults when converting some mbx folders back to the default mbox format.  It only does this for a few mbx folders, but for those folders that are affected, it segfaults every time.

Version-Release number of selected component (if applicable):
imap-utils-2002d-11

How reproducible:
Always

Steps to Reproduce:
1. Create a bunch of mbx-format mailboxes using one of the methods described in section 4.5 of the UW-IMAP FAQ (http://www.washington.edu/imap/IMAP-FAQs/index.html).
2. Store mail in the mailboxes.
3. Try to convert the mailboxes back to mbox format using mailutil: run "mailutil copy mailboxname mailboxname.new"
  

Actual Results:  Segmentation fault

Expected Results:  Successful copy/format conversion

Additional info:

This bug does not exist in an unpatched compilation of imap-2004e (the latest version), built for the lrh target.  It does exist in an unpatched install of imap-2004d, built for the lrh target, so it looks like imap-2004e fixes the bug.

I can submit copies of several mbx mail folders that trigger this bug upon request.
Comment 1 Josh Kelley 2005-06-27 23:08:30 EDT
I made an error: the bug does exist in an unpatched install of imap-2002d.  I
did not test imap-2004d.
Comment 2 RHEL Product and Program Management 2007-10-19 14:59:33 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.