Bug 161895 - Kernel panic after upgrade, when finding the volume groups
Kernel panic after upgrade, when finding the volume groups
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Alasdair Kergon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-28 05:02 EDT by Sergio Pascual
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version: old
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-10 12:53:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output of the console during the boot process (443 bytes, text/plain)
2005-06-28 05:03 EDT, Sergio Pascual
no flags Details

  None (edit)
Description Sergio Pascual 2005-06-28 05:02:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Galeon/1.3.21

Description of problem:
I have made a upgrade of my system from fc3 to fc4. The upgrade was finished correctly. My / file system is in lvm. This are the kernel options I use:

kernel /vmlinuz-2.6.11-1.1369_FC4 ro root=/dev/vg0/root quiet

After the reboot, the system hangs when finding the volume groups with a kernel panic (I attach the kernel message).

Oddly, the system does work with fc3 kernel: kernel-2.6.11-1.27_FC3
This is the kernel I am using now

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1369_FC4

How reproducible:
Always

Steps to Reproduce:
1. Have a fc3 system with lvm
2. Do an update to fc4
3. Reboot
  

Actual Results:  The kernel do not find any volume group.
The system stops booting and the kernel issue a kernel panic message.

Expected Results:  The kernel should find a volume group and continue booting with root /dev/vg0/root

Additional info:

This problem has appeared in the fedora mailing list
https://www.redhat.com/archives/fedora-list/2005-June/msg03100.html
with no answer.
Comment 1 Sergio Pascual 2005-06-28 05:03:54 EDT
Created attachment 116047 [details]
Output of the console during the boot process
Comment 2 Adrian McMenamin 2005-06-28 10:46:38 EDT
I had a very similar problem. This seems to be because the initrd generated by
the installer does not include appropriate modules.

Does your machine boot with the rescue CD (or with Disk1 in rescue mode?).

Have a look at 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=161911

Which is my report of my problem and the fix I applied
Comment 3 Sergio Pascual 2005-06-29 06:31:37 EDT
I have made an install (insted of an upgrade) and the system works without
any problem.
Comment 4 Jacek Piskozub 2005-07-02 11:03:15 EDT
I've seen the same problem (or at least too related to open a new bug) with
kernels  kernel-2.6.12-1.1385_FC4 and kernel-2.6.12-1.1387_FC4 but not
kernel-2.6.11-1.1369_FC4.

If a CDROM is in the DVD drive, kernel panicks during the LVM check. I receive
at least one page of crap full of cdrom related errors. If there is no CDROM in
the drive, the boot succeeds but with a worning (something about LVM not able to
open /dev/cdrom).

I applied the obvious workaround and enabled a commented-out line in
/etc/lvm/lvm.conf, namely the second line below:

    # Exclude the cdrom drive
    filter = [ "r|/dev/cdrom|" ]

Now the system boots fine with and without a CDROM disk inside the drive.

The computer is a Pentium 3 with an Intel chiset 815E matherboard (ASUS
CUSL2-C). The DVD drive is a JLMS XJ-HD166S (everything purchased in early 2001).
Comment 5 Ken Prox 2005-09-30 22:23:25 EDT
Have a similar sounding problem here.  I installed a new hard drive at /dev/hdc,
created /dev/hdc1 for boot, /dev/hdc2 for /, and /dev/hdc3 for LVM's.

The drive booted and worked fine when an entry on the old drives (/dev/hda)
grub.conf was made for booting from /dev/hdc.  But when the drive was moved from
/dev/hdc to /dev/hda, with the appropriate changes to /etc/fstab of course, it
would boot but fail to find the LVM's.

If the following line in /etc/rc.sysinit was changed

From:

action $"Setting up Logical Volume Management:" /sbin/lvm.static vgchange -a y
--ignorelockingfailure

To:

action $"Setting up Logical Volume Management:" /sbin/lvm.static vgchange -a y
--ignorelockingfailure VolGroup00

Thereby specifying VolGroup00, the drive works fine, and all LVM's are detected
at boot, all is happy now.

All the gory details of the drive upgrade can be found here:
http://forums.fedoraforum.org/showthread.php?t=79448
Comment 6 Alasdair Kergon 2007-01-10 12:53:09 EST
If there are still problems, please reopen (or create new bugs) against fc6 or
devel.

Note You need to log in before you can comment on or make changes to this bug.