Bug 161897 - nautilus generates wrong time/date
nautilus generates wrong time/date
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-28 06:17 EDT by Steve
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-19 03:30:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve 2005-06-28 06:17:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
i've a few linux systems (fc4) and a samba-server (rh9). all are
time-servered and have the same date and time . now, when i create a
folder on any destop (gnome) and copy them to the samba-share with
command line:
"cp -Rvp folder/ /mnt//share" the time and date are right. But when i
copy them with naulilus with drag and drop, the date is something like
"december 1979". so i think nautilus generates this date or he copy them
without the "-p" parameter.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. right click the desktop (create folder)
2. copy the folder (in nautilus)
3. paste the folder to a samba share (in nautilus)

Actual Results:  none

Expected Results:  none

Additional info:

clients - fc4
server - rh9
Comment 1 Robin Gape 2005-07-22 21:12:09 EDT
Colleagues,

on a PIII system with a number of IDE HD partitions, a USB HD drive and an smb
mounted Buffalo Linkstation (to offer some variety and resilience, you
understand) then, using Nautilus:

a) copy a file from the IDE HD: file seems to copy OK to all destinations, with
the date intact

b) copy a folder from the IDE HD, selected from the file pane: USB drive folder
date is 1970-01-01 01:00:00, smb mounted folder date is 1980-01-01 00:00:00, HD
ext3 partition folder date is 1970-01-01 01:00:00, HD vfat partition folder date
is 1970-01-01 01:00:00

c) copy a folder from the IDE HD, selected from the tree pane (a right click
offers to copy folder): USB drive folder date is 1970-01-01 01:00:00, smb
mounted folder date is 1980-01-01 00:00:00, HD ext3 partition folder date is
1970-01-01 01:00:00, HD vfat partition folder date is 1970-01-01 01:00:00

d) a folder which was copied last week, on another machine runing FC4, has a
date of 1979-12-31 23:00:00

e) when copying a folder with a large number of files in, then Nautilus shows
the correct destination folder date as copying proceeds, and changes the folder
date immediately after the copying has completed to the bogus 1970 date.

f) copying using the shell seems to behave correctly.

This is, of course, a bore! This behaviour was not seen with FC3.

Thanks for your attention. Is there any thing else that one might do to help
diagnose this problem?

Robin
Comment 2 Benno Stein 2005-08-16 07:26:51 EDT
I encountered the same problem:

Each copy and paste operation of a folder done with Nautilus has the effect that
the new folder as well as its subfolders get the time stamp "Jan  1  1970". The
time stamps of the files are not affected.

Kernel release: 2.6.12-1.1398_FC4smp
Nautilus version: 2.10.0

How reproducible:
Always

Steps to Reproduce:
1. copy the folder (in nautilus)
2. paste the folder (in nautilus)

or

1. duplicate the folder (in nautilus)

Benno
Comment 3 Osmo Laitinen 2005-11-16 17:05:11 EST
I can also confirm this with USB flash drive (Creative Muvo).

If I copy dir and its content in Nautilus
- Folder will have date 1970 or 1980 etc
- Files has correct date

If I copy dir and its content in terminal (cp -a dir)
- ctime of both folder and files are correct

USB is automounted:
/dev/sda1 on /media/usbdisk type vfat
(rw,nosuid,nodev,_netdev,fscontext=system_u:object_r:removable_t,user=osmo)

 
Comment 4 Osmo Laitinen 2005-11-17 15:30:25 EST
Kernel is 2.6.14-1.1637_FC4

And one strange thing: folders has correct timestamps in OS X 1.3.x
But not in this FC4
Comment 5 Alexander Larsson 2005-12-16 05:50:52 EST
I just tried to reproduce this on various machines (FC4 and rawhide), and i
totally failed. I don't have a usb HD, so i just tried to copy it to a usb flash
memory. 

Am I right in that you are copying (drag and drop) a file from a "normal"
location  (e.g. in homedir on ext3 partition) to a removable device (fat/vfat
mount)?

Can someone who gets this try something like:
gnomevfs-copy /home/alex/test_folder /media/hd_name/
which should copy the test folder and contents to /media/hd_name/test_folder.
I'm interested in if this causes the same problem, and if so, I would like the
output of:
strace -o copy.log gnomevfs-copy /home/alex/test_folder /media/hd_name/
(i.e. run that with the right filenames and attach copy.log)
Comment 6 Steve 2005-12-16 06:11:13 EST
(In reply to comment #0)
> From Bugzilla Helper:
> User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524
Fedora/1.0.4-4 Firefox/1.0.4
> 
> Description of problem:
> i've a few linux systems (fc4) and a samba-server (rh9). all are
> time-servered and have the same date and time . now, when i create a
> folder on any destop (gnome) and copy them to the samba-share with
> command line:
> "cp -Rvp folder/ /mnt//share" the time and date are right. But when i
> copy them with naulilus with drag and drop, the date is something like
> "december 1979". so i think nautilus generates this date or he copy them
> without the "-p" parameter.
> 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:
> Always
> 
> Steps to Reproduce:
> 1. right click the desktop (create folder)
> 2. copy the folder (in nautilus)
> 3. paste the folder to a samba share (in nautilus)
> 
> Actual Results:  none
> 
> Expected Results:  none
> 
> Additional info:
> 
> clients - fc4
> server - rh9

i just upgraded the server to fc4 and latest samba and the problem is gone.
Comment 7 Alexander Larsson 2005-12-16 06:15:09 EST
That doesn't explain the problem people had with USB drives though.
Comment 8 Steve 2005-12-16 06:23:01 EST
(In reply to comment #7)
> That doesn't explain the problem people had with USB drives though.

i know that. but i can't explain the problem anyway.
Comment 9 Alexander Larsson 2005-12-19 03:30:37 EST
This seems to be fixed upstream:

http://bugzilla.gnome.org/show_bug.cgi?id=303470

This should be in rawhide now.

Note You need to log in before you can comment on or make changes to this bug.