Bug 161924 - amarok gets symbol lookup error when trying to build a collection
amarok gets symbol lookup error when trying to build a collection
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-28 10:42 EDT by Diego Novillo
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-28 12:22:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Diego Novillo 2005-06-28 10:42:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:

Everytime I tell amarok to build a collection it shuts down.

Version-Release number of selected component (if applicable):
amarok-1.2.4-6.fc4

How reproducible:
Always

Steps to Reproduce:
1. start amarok
2. choose 'Build a collection'
3. select a directory.
  

Actual Results:  
amarok shuts down with these errors:

amaroK: [Loader] Starting amarokapp..
amaroK: [Loader] Don't run gdb, valgrind, etc. against this binary! Use amarokapp.
amarokapp: symbol lookup error: amarokapp: undefined symbol: _ZN6TagLib7FileRefC1Ev
X Error: BadWindow (invalid Window parameter) 3
  Major opcode:  7
  Minor opcode:  0
  Resource id:  0x38000af

Expected Results:  
The selected directory should be scanned and the play list populated.

Additional info:


At first I thought the error was related to my desktop being GNOME, but I switchdesk'd to KDE and got the exact same results.
Comment 1 Michael Schwendt 2005-06-28 11:18:38 EDT
What do you get for "rpm --query taglib"?
Comment 2 Diego Novillo 2005-06-28 11:27:34 EDT
Ah, that's indeed the problem:

$ rpm --query taglib
package taglib is not installed

Installing taglib fixed the failure.  Odd that amarok could be installed with
that missing dependency (I did a default upgrade from FC3 to FC4).

Thanks.  Diego.
Comment 3 Aurelien Bompard 2005-06-28 11:49:03 EDT
Odd indeed:
$ rpm -qR amarok | grep tag
libtag.so.1
$ rpm -q --whatprovides libtag.so.1
taglib-1.3.1-2
Comment 4 Michael Schwendt 2005-06-28 12:04:19 EDT
So, what do you get for "rpm -qf /usr/lib/libtag*" and "rpm -q --whatprovides
libtag.so.1"? It smells much like some incompatible taglib from a 3rd party repo
could be installed.
Comment 5 Diego Novillo 2005-06-28 12:09:32 EDT
Hmm, indeed.  I do have to libtag.so.1 providers.  I have no idea where I got
the other one from.  I tried uninstalling it, but I'm getting:

$ sudo rpm -e libtag
/var/tmp/rpm-tmp.57225: line 1: /sbin/postun_ldconfig: No such file or
directoryerror: %postun(libtag-1.1-alt1.i586) scriptlet failed, exit status 127


$ rpm -qf /usr/lib/libtag*
libtag-1.1-alt1
taglib-1.3.1-2
taglib-1.3.1-2
libtag-1.1-alt1
taglib-1.3.1-2
libtag-1.1-alt1
taglib-1.3.1-2

$ rpm -q --whatprovides libtag.so.1
libtag-1.1-alt1
taglib-1.3.1-2

$ rpm -qi libtag
Name        : libtag                       Relocations: (not relocatable)
Version     : 1.1                               Vendor: ALT Linux Team
Release     : alt1                          Build Date: Thu Apr  8 13:05:10
2004Install Date: Mon Sep 13 10:19:03 2004      Build Host:
zerg.hasher.altlinux.orgGroup       : System/Libraries              Source RPM:
libtag-1.1-alt1.src.rpm
Size        : 242912                           License: GPL
Signature   : DSA/SHA1, Wed Apr 21 08:57:42 2004, Key ID fb3048af1c2a3f08
Packager    : Sergey V Turchin <zerg at altlinux dot org>
URL         : http://ktown.kde.org/~wheeler/taglib/
Summary     : TagLib, is well, a library for reading and editing audio meta
dataDescription :
TagLib, is well, a library for reading and editing audio meta data,
commonly know as tags.
Some goals of TagLib:
        A clean, high level, C++ API to handling audio meta data.
        Support for at least ID3v1, ID3v2 and Ogg Vorbis comments.
        A generic, simple API for the most common tagging related functions.
        Binary compatibility between minor releases using the standard KDE/Qt
        techniques for C++ binary compatibility.
        Make the tagging framework extensible by library users; i.e. it will be
        possible for libarary users to implement additional ID3v2 frames,
        without modifying the TagLib source.
Because TagLib desires to be toolkit agnostic, in hope of being widely
adopted and the most flexible in licensing TagLib provides many of its
own toolkit classes; in fact the only external dependancy that TagLib has,
it a semi-sane STL implementation.
Comment 6 Michael Schwendt 2005-06-28 12:22:14 EDT
Looks like you downloaded an arbitrary package from rpmfind.net or so. C++ ABI
breakage.

To recover:
sudo rpm -e --nodeps --noscripts libtag taglib ; yum install taglib
Comment 7 Diego Novillo 2005-06-28 12:26:24 EDT
That worked.  Thanks for the quick help!

Note You need to log in before you can comment on or make changes to this bug.