Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 161996 - several RPMs require /usr/bin/rebuild-security-providers but dont list it in dependencies
several RPMs require /usr/bin/rebuild-security-providers but dont list it in ...
Product: Fedora
Classification: Fedora
Component: jpackage-utils (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Fitzsimmons
Depends On:
  Show dependency treegraph
Reported: 2005-06-28 19:23 EDT by Dan Hollis
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-03 20:12:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Dan Hollis 2005-06-28 19:23:22 EDT
Description of problem:
several RPMs require /usr/bin/rebuild-security-providers in their %postun, but
said RPMs do not list this as a dependency.

thus it is possible to eg rpm -e jpackage-utils and
/usr/bin/rebuild-security-providers will disappear. then it becomes difficult to
rpm -e these other packages because they error out trying to call a nonexistent
/usr/bin/rebuild-security-providers in their %postun.

it is possible to rpm -e these broken rpms with --noscripts, but meh. it
shouldnt be needed.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.rpm -e jpackage-utils
2.rpm -e (various other java packages)
3.join communist party
Actual results:
profit! :-(

Expected results:
It should uninstall them without barfing (or rather, trying to remove
jpackage-utils should whine that it would break dependencies in other packages
due to their dependency on /usr/bin/rebuild-security-providers)

Additional info:
Comment 1 Matthieu Pupat 2005-07-03 07:53:14 EDT
confirmed with:


Same problem with update-desktop-database for:

Comment 2 Thomas Fitzsimmons 2005-10-01 17:40:04 EDT
Yes, I plan to create a separate java-gcj-compat-scripts package that includes
/usr/bin/rebuild-security-providers.  Then packages that use
rebuild-security-providers can require this -scripts package.

Please file separate bug reports against openoffice.org-core and redhat-menus.
Comment 3 Thomas Fitzsimmons 2006-02-03 20:12:33 EST
java-1.4.2-gcj-compat, gnu-crypto and jessie now contain these Requires lines:

Requires(post): jpackage-utils >= 0:1.6.3-1jpp_1rh
Requires(postun): jpackage-utils >= 0:1.6.3-1jpp_1rh

rebuild-security-providers was introduced in jpackage-utils-1.6.3-1jpp_1rh. 

Note You need to log in before you can comment on or make changes to this bug.