Bug 162002 - VNC Server abruptly closes connections after upgrade from FC3 to FC4
VNC Server abruptly closes connections after upgrade from FC3 to FC4
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
ww2.sleekcollar.com:5900
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-28 20:25 EDT by Ferindo Middleton Jr
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-03 05:30:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log file in .vnc folder of local user on system trying to connect to server (587 bytes, text/plain)
2005-06-28 20:33 EDT, Ferindo Middleton Jr
no flags Details
output to shell screen after running vncviewer 192.168.1.2 (1.29 KB, text/plain)
2005-06-28 20:42 EDT, Ferindo Middleton Jr
no flags Details
The gdm.conf GNOME DISPLAY MANAGER configuration file on this server (20.78 KB, text/plain)
2005-07-01 19:35 EDT, Ferindo Middleton Jr
no flags Details
steps I used to setup this VNC server (93.03 KB, text/html)
2005-07-01 19:39 EDT, Ferindo Middleton Jr
no flags Details

  None (edit)
Description Ferindo Middleton Jr 2005-06-28 20:25:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
I Unable to connect to VNC Server from Win2000 client or local VNC client bundled with FC4. It used to work fine, but after upgrading to FC4, the VNC clients both local on the system and clients running on Windows PC remotely react the same when trying to connect to server - the VNC window opens briefly (with the preliminary blue screen) and then closes abruptly with out any error message or warning of error that occured. 

VNC services ran perfectly on FC3. Remote clients used to connect to VNC Server and connect to machine as expected. After upgrading to FC4, there is suddenly some unreported problem.

This is what's been tested and know to be fact on this server:
1. I'm sure the VNC Server is running and excepting connections
2. The Windows VNC client and  Linux  Fedora Core 4 Server running VNC Server are on the same LAN (Problem occurs with local VNC client the same way anyway)
3. Nothing is being prohibited in my server's host.deny file
4. When I try to connect to Server from VNC client the client window opens for a couple brief seconds with a blue screen and then closes
5. It does the same thing even when I use a VNC client running locally on the server
6. VNC connections used to work fine before I recently upgraded from FC3 to Fedora Core 4
7. I've tried opening up my system more by turning off iptables and SELinux but that doesn't seem to be the reason
I've looked through troubleshooting guides available from realvnc.com and some affiliates and just can't figure out what's suddenly going wrong and why my vnc clients are abruptly closing when trying to connect. The Server seems ready to go but something goes wrong. When I look in the client logfiles.. it's doesn't say anything is going wrong and it seems as though a connection was made successfully. 
8. For some strange reason, when I run the local VNC client on the FC4 server, it doens't always generate a logfile in .vnc or a new append to the existing logfiles there
9. Logwatch generated daily and sent to root account appear to recognize the connections as being mde successfully, which implies the Xvnc server doesn't recognize the connections are being lost really 

Version-Release number of selected component (if applicable):
vnc-server-4.1.1-10, gdm-2.6.0.8-16

How reproducible:
Didn't try

Steps to Reproduce:
1. Started out with FC3 and VNC connections capable and working just fine
2. Upgrade to FC4 and suddenly VNC client window closes abruptly 1 to 2 seconds after making inital connection to server
3.(No configuration changes made and all configuration of dependent files for VNC to work are in place still and 'XDMCP' IN gdm component configured to accept incoming vnc connections
  

Actual Results:  While eveything is in place as was before upgrade from FC3, the Xvnc server seems to be closing the incoming connections for some unknown reason that isn't being reported in logfiles.

Expected Results:  VNC connection to VNC-Server should stay open showing local GDM login-screen on the host machine...

Additional info:

Because I didn't make any changes to the system before it started abruptly closing vnc connections after the upgrade from FC3, and there no errors being reported in log files concerning this, there must be a bug somewhere either with xvnc, the vnc-server package, or some other initialization, configuration script problem with the inital desgn of the VNC server on Fedora.
Comment 1 Ferindo Middleton Jr 2005-06-28 20:33:58 EDT
Created attachment 116100 [details]
log file in .vnc folder of local user on system trying to  connect to server

This logfile show that nothing is going wrong with the VNC connections
attempted... However, I just ran this local vnc client and for some strange
reason, a log file was not created or an existing logfile was appended....
Maybe this has something to do with what's wrong even though nothing is
reported...
Comment 2 Ferindo Middleton Jr 2005-06-28 20:42:26 EDT
Created attachment 116101 [details]
output to shell screen after running vncviewer 192.168.1.2

The ip address of the FC4 machine in question running the VNC Server is
192.168.1.2    This is the output that displays on the shell screen (after of
course the vnc window opens briefly like it's connected and then abruptly
closes beforee showing the login screen).
Comment 3 Tim Waugh 2005-06-29 04:12:26 EDT
How are you starting the VNC server?  There are several different ways you might
be doing it, so I need to know which.
Comment 4 Ferindo Middleton Jr 2005-06-29 18:16:00 EDT
(In reply to comment #3)
> How are you starting the VNC server?  There are several different ways you might
> be doing it, so I need to know which.

The VNC server starts up as a service from /usr/bin/Xvnc. I never had to
manually start it. I always just used the "Service Configuration" Tool in the
Gnome interface to check the service to automatically start on reboots... I'm
not exactly sure if this is the way it should be because when I am on the shell
and run '/sbin/service vncserver status' I get the following output 'Xvnc is
stopped', however, if I run '/sbin/service vncserver start', I get the following
output: 
Starting VNC server:           [  OK  ]

But if I run '/sbin/service vncserver status' again, it says 'Xvnc is stopped'
again. I don't remember the way it was with FC3, but should this service remain
running in the background after being started initially?... It always just
worked with FC3.
Comment 5 Tim Waugh 2005-06-30 04:20:43 EDT
Please show me the output of these commands:

cat /etc/sysconfig/vncservers
ls -l ~/.vnc
Comment 6 Ferindo Middleton Jr 2005-06-30 21:12:17 EDT
(In reply to comment #5)
> Please show me the output of these commands:
> 
> cat /etc/sysconfig/vncservers
> ls -l ~/.vnc

[s068913@localhost ~]$ cat /etc/sysconfig/vncservers
# The VNCSERVERS variable is a list of display:user pairs.
#
# Uncomment the line below to start a VNC server on display :1
# as my 'myusername' (adjust this to your own).  You will also
# need to set a VNC password; run 'man vncpasswd' to see how
# to do that.
#
# DO NOT RUN THIS SERVICE if your local area network is
# untrusted!  For a secure way of using VNC, see
# <URL:http://www.uk.research.att.com/vnc/sshvnc.html>.

#VNCSERVERS="1:s068913"

[s068913@localhost ~]$ ls -l ~/.vnc
total 68
-rw-rw-r--  1 s068913 s068913 2465 Jun 27 18:35 localhost:2.log
-rw-rw-r--  1 s068913 s068913    6 Jun 25 22:51 localhost:2.pid
-rw-rw-r--  1 s068913 s068913    6 Jun 25 22:51 localhost:3.pid
-rw-------  1 s068913 s068913    8 May 21  2004 passwd
-rw-rw-r--  1 s068913 s068913 3897 May 22  2004 scnmaster.sleekcollar.com:1.log
-rw-rw-r--  1 s068913 s068913 5820 May 22  2004 scnmaster.sleekcollar.com:2.log
-rw-rw-r--  1 s068913 s068913    5 May 22  2004 scnmaster.sleekcollar.com:2.pid
-rwxr-xr-x  1 s068913 s068913  334 May 21  2004 xstartup

Comment 7 Tim Waugh 2005-07-01 04:18:59 EDT
You need to actually configure a server in the vncservers file.  All of the
lines in that file are comments at the moment.  You need to set the VNCSERVERS
variable -- perhaps you forgot to take out the '#' character when changing that
line before?
Comment 8 Ferindo Middleton Jr 2005-07-01 19:25:51 EDT
(In reply to comment #7)
> You need to actually configure a server in the vncservers file.  All of the
> lines in that file are comments at the moment.  You need to set the VNCSERVERS
> variable -- perhaps you forgot to take out the '#' character when changing that
> line before?

No, I don't think you understand (Or rather I understand a little better after
researching how I've been VNCing, please excuse me)

I've been using VNC with GDM. GDM runs in the background (with no X-Server in
this config). When I start a VNC session, VNC contacts the GDM to display the
"Greeter"...then I log in as I normally do with GDM locally. I think the bug
should still really be open - I think the bug is with GDM possibly. I'm going to
attach my /etc/X11/gdm/gdm.conf file so you can see I've got GDM configured to
allow incoming connections like VNC's... 

So I don't think I'm really using the cat /etc/sysconfig/vncservers file because
 authentication should be handled by GDM. I'm sorry for not explaining the
problem better.

I'm going to also attach a file I referrenced when origianlly setting up my VNC
 a couple of Fedora releases ago or so. This file shows the general steps I
sused to setup my VNC so you can undertstand that the problem maybe really
involves so flaw with GDM... possibly dissalowing VNC connections. I realy think
this is still a bug that should be fixed. Please reconsider.
Comment 9 Ferindo Middleton Jr 2005-07-01 19:35:15 EDT
Created attachment 116269 [details]
The gdm.conf GNOME DISPLAY MANAGER configuration file on this server

Use this as a referrence to determine that I atleast have my gdm configuration
correct enough to allow the VNC connections that should be allowed on this
server.
Comment 10 Ferindo Middleton Jr 2005-07-01 19:39:48 EDT
Created attachment 116270 [details]
steps I used to setup this VNC server

Use this as a reference to determining the steps I used to setup my VNC
connections to happen via the Gnome Display Mananger and not to authenticate
via the /etc/X11/gdm/gdm.conf
Comment 11 Ferindo Middleton Jr 2005-07-01 19:59:28 EDT
James Weatherall of RealVNC Ltd. reccommended that I look into why no logfile is
being generated before trying to debug the connection issue.  I he said that the
vncserver will always cause Xvnc and the other processes it spawns (such as the
local VNC client running on the FC4 release) to write to a logfile in the .vnc
directory.... So the fact that mine isn't generating a logfile my be a pointer
to where the flaw is occuring.
Comment 12 Tim Waugh 2005-07-03 05:30:38 EDT
Okay, it would have been good if you'd mentioned that this is the method you are
using when I asked in comment #3 how you are starting VNC.  The 'vncserver' init
service is nothing to do with how you are starting VNC in your xinetd configuration.

The method you are using will not generate a log file in your ~/.vnc directory.

I would suggest you use an easier-to-configure method of using a VNC server. 
The method you are trying is very fiddly to get right, and the problems you are
seeing are most likely to be due to errors in your xinetd.d configuration file.

Note You need to log in before you can comment on or make changes to this bug.