Bug 162034 - HP laserjet 2100 entry is wrong
Summary: HP laserjet 2100 entry is wrong
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: foomatic   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-29 11:31 UTC by Hans de Goede
Modified: 2008-01-10 14:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-10 14:42:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hans de Goede 2005-06-29 11:31:18 UTC
My printer is a HP Laserjet 2100, this one contains in the foomatic xml file:
<driver>Postscript</driver>

This causes a traceback in printconf (see bug 162033), but is also wrong since
the 2100 is PCL only the 2100M is the postscript version.

Next I tried selecting the 2100M which funny enough doesn't default to
postscript but to plxmono as driver. This works but the top 2 cm of the page go
missing and a bit of the leftside. I think this is caused by the ghostscript
upgrade since it used to work. selecting ljet5gray as driver fixes the printing
of the page problem (but is a bit slow)

Comment 1 Tim Waugh 2005-06-29 14:25:54 UTC
Waiting to hear from upstream if the change to PostScript was intended to go
into the 2100M XML file instead.

Comment 2 Hans de Goede 2007-07-27 08:22:22 UTC
This is still wrong in current rawhide, the 2100M entry says:
  <driver>Postscript</driver><!--verified--><!--affiliate keys; modify and face
my wrath!-->

...
  
    Note: The recommended driver is set to &quot;pxlmono&quot; here
    because the printer returns the same answer to auto-detection
    requests as its little PostScript-less brother, LaserJet 2100
    (without &quot;M&quot;). So Foomatic frontends which choose the
    printer model by the auto-detection info will not fail when the
    user has only the printer without PostScript.&lt;p&gt;

?

And the 2100 entry says:
    <postscript level="2">
    <ppd>PPD/HP/HP_LaserJet_2100_Series.ppd</ppd>
    </postscript>

which is wrong for the plain 2100

Note I no longer have access to the printer for testing.


Comment 3 Tim Waugh 2008-01-10 14:42:01 UTC
As HP made these two devices respond with the same Device ID, *and* they provide
their own PPD which gives its make-and-model as 'HP LaserJet 2100 Series
Postscript', there is not very much we can do about this.


Note You need to log in before you can comment on or make changes to this bug.