Bug 16204 - [net] Bad behavior if FTP account has cdrom-dir as home
Summary: [net] Bad behavior if FTP account has cdrom-dir as home
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Erik Troan
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-14 23:47 UTC by Enrico Scholz
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-16 12:40:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2000-08-14 23:47:16 UTC
When using FTP install and choosing a FTP account having /mnt/cdrom as it
home it's difficulty to enter the correct "Red Hat directory":

0. Create FTP account `cdrom' having /mnt/cdrom as it home and mount CD1
there

1. Install from bootnet.img
2. Choose FTP install
3. Try to choose "Red Hat directory":
   - leaving path empty doesn't work ("You must enter a directory")
   - '/' results in "Failed to retrieve: //RedHat/base/netstg1.img: File
not found on server"

It's not trivially to find the correct input '.' for 3)...

Comment 1 Erik Troan 2000-08-16 12:40:02 UTC
Couldn't reproduce this, but I suspect it depends on the ftp server you're
using. I put a workaround in anaconda to convert / to /. internally, which
should fix this in all cases.


Note You need to log in before you can comment on or make changes to this bug.