Bug 162113 - hibernate resumes immediately on Inspiron 9300
hibernate resumes immediately on Inspiron 9300
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-29 20:11 EDT by Bertil Askelid
Modified: 2015-01-04 17:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-24 13:13:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Suspund script that handles suspend to RAM and to disk. (1.40 KB, text/plain)
2005-07-15 22:47 EDT, Bertil Askelid
no flags Details
dmesg after hibernate attempt on kernel-2.6.14-1.1653_FC4 (20.97 KB, text/plain)
2005-12-20 11:01 EST, Bertil Askelid
no flags Details

  None (edit)
Description Bertil Askelid 2005-06-29 20:11:47 EDT
Description of problem:

hibernate doesn't do anything at all.

Version-Release number of selected component (if applicable):

kernel-2.6.11-1.1369_FC4

How reproducible:

Always.

Steps to Reproduce:
1.echo -n disk > /sys/power/state
2.
3.
  
Actual results:

Nothing happens. The /etc/acpi/action scripts just resumes right away.

Expected results:

suspend-to-disk expected and machine turned off.

Additional info:

Both suspend to RAM and suspend to disk work just fine in my dual booted Windows
, i.e. hardware is OK.

I also reported a problem (162112) with suspend-to-RAM that at resume don't 
start HD.

~> lspci
00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express
Processor to DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 915GM/PM Express PCI Express Root
Port (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #4 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d3)
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW
(ICH6 Family) AC'97 Audio Controller (rev 03)
00:1e.3 Modem: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem
Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801FBM (ICH6M) SATA Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus
Controller (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Radeon Mobility M300]
03:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
03:01.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b3)
03:01.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 08)
03:01.2 Class 0805: Ricoh Co Ltd SD Card reader (rev 17)
03:03.0 Network controller: Intel Corporation PRO/Wireless 2915ABG MiniPCI
Adapter (rev 05)
04:00.0 Ethernet controller: D-Link System Inc DFE-690TXD CardBus PC Card (rev 10)
~>
Comment 1 Bertil Askelid 2005-07-02 13:57:05 EDT
Tested kernel-2.6.12-1.1387_FC4 -- same problem.
Comment 2 Dave Jones 2005-07-15 17:01:54 EDT
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.
Comment 3 Bertil Askelid 2005-07-15 22:47:37 EDT
Created attachment 116831 [details]
Suspund script that handles suspend to RAM and to disk.
Comment 4 Bertil Askelid 2005-07-15 22:48:24 EDT
I tried this on linux-2.6.12-1.1398_FC4. Same problem as before. echo -n disk >
/sys/power/state has no effect on anything. Resumes right away. 

I have also added my Suspend script so you can see exactly what I doing.
Comment 5 Dave Jones 2005-08-26 04:35:17 EDT
Not all BIOS's implement S4BIOS sleep (which you are attempting). There's
nothing we can do about this.  In FC5, hopefully we'll be able to ship software
suspend support.

(in fact, S4BIOS works on so few machines, its destined for removal in a future
upstream kernel).
Comment 6 Bertil Askelid 2005-08-27 07:08:12 EDT
Inspiron 9300 has this to say in /var/log/messages after reboot:

   ACPI: (supports S0 S3 S4 S4bios S5)

so hibernate is supported. Also, when I boot into my Windows XP partition and
try suspend and hibernate from there, it works just fine. So the hardware and
the BIOS support both suspend-to-RAM and suspend-to-disk.
Comment 7 Dave Jones 2005-09-30 02:00:17 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 8 Bertil Askelid 2005-10-01 18:17:34 EDT
Using kernel-2.6.13-1.1526_FC4 I still see the same behavior on echo -n disk >
/sys/power/state. Goes through my /etc/acpi/actions/Suspend script, resumes
right away, then it runs my script once more and resumes again.
Comment 9 Dave Jones 2005-11-10 13:56:22 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 10 Bertil Askelid 2005-11-12 09:14:36 EST
The bug still remains with the same symptoms as described
above. kernel-2.6.14-1.1637_FC4 does not fix it.
Comment 11 Bertil Askelid 2005-12-17 23:22:32 EST
kernel-2.6.14-1.1653_FC4: no changes, resumes right away, tries once more to
suspend to DISK but resumes immediately and then gives up, leaving the system
running.
Comment 12 Dave Jones 2005-12-19 22:38:34 EST
after a failed suspend, there should be debug output in 'dmesg'. please attach
that output.
Comment 13 Bertil Askelid 2005-12-20 11:01:53 EST
Created attachment 122448 [details]
dmesg after hibernate attempt on kernel-2.6.14-1.1653_FC4
Comment 14 Dave Jones 2005-12-23 22:10:57 EST
odd, there's no sign in that dmesg that a suspend was even attempted.
Comment 15 Bertil Askelid 2005-12-24 13:13:32 EST
Thanks to the excellent ACPI-HOWTO at 

   http://www.columbia.edu/~ariel/acpi/acpi_howto.txt

I finally started to understand what is going on. Even though dmesg tells me that
suspend-to-disk (S4) is supported: ACPI: (supports S0 S3 S4 S5), it turns out
that the FC4 kernel I have "out-of-the-box", doesn't have CONFIG_SOFTWARE_SUSPEND
set in the /usr/src/kernels/2.6.14-1.1653_FC4-i686/.config. Sorry I missed this.

Now, I'd like to recompile the kernel. How do I do that? I have some old
description that I used for FC2 to recompile, but that doesn't work anymore.
Where can I find a new description of how to compile the kernel on current
systems FC4?

For the time being, I close this bug.
Comment 16 Dave Jones 2005-12-24 15:39:14 EST
software suspend also requires userspace changes to mkinitrd. These have been
done in FC5, and the kernel has software suspend enabled there.

Note You need to log in before you can comment on or make changes to this bug.