Bug 162145 - 'nend' is used uninitialized in this function
'nend' is used uninitialized in this function
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: iiimf (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
:
: 162309 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-30 06:12 EDT by David Binderman
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 14:33:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Binderman 2005-06-30 06:12:23 EDT
Description of problem:

I just tried to compile package iiimf-12.2-4 from Redhat
Fedora Core development tree with the gcc 4.0.0 compiler and
the compiler flag -Wall.

The compiler said

EIMILTextUtil.c:1489: warning: 'nend' is used uninitialized in this function

The source code is

	pprop->st = nend;

I agree with the compiler. Suggest initialise local variable "nend"
before first use.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Akira TAGOH 2005-07-04 00:46:11 EDT
*** Bug 162309 has been marked as a duplicate of this bug. ***
Comment 2 Akira TAGOH 2005-09-21 14:33:09 EDT
EIMIL isn't used for anything actually. so I doubt this affects anything and
it's worthless to try to fix since IIIMF has been removed from Core now.

Note You need to log in before you can comment on or make changes to this bug.