Bug 162148 - Xen0 trouble loading aic7xxx module
Xen0 trouble loading aic7xxx module
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rik van Riel
Depends On:
Blocks: 179599
  Show dependency treegraph
Reported: 2005-06-30 07:30 EDT by Chris Evich
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-24 15:43:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
dmesg output (13.30 KB, text/plain)
2005-07-01 09:25 EDT, Chris Evich
no flags Details
strace output (3.41 KB, text/plain)
2005-07-01 09:27 EDT, Chris Evich
no flags Details

  None (edit)
Description Chris Evich 2005-06-30 07:30:35 EDT
Domain 0 xen kernel has problems with scsi card on athlon system with stock FC4
xen kernel.  The card is an older Adaptec 2940 which works flawlessly using the
regular kernel.  The system is booting from a software raid mirror on the local
IDE disks.  The only thing connected to the 2940 is an old Teac CDR drive.
Everything works fine until the system tries to insmod aic7xxx.  At that point
it 'hangs', repeatidly resetting the scsi bus and sending abort commands.  I've
tried changing the IRQ settings for the card, disabeling xen (and the kernel)
acpi support, booting into emergency mode and insmoding aic7xxx by hand.
Comment 1 Chris Evich 2005-07-01 09:13:53 EDT
from emergency mode, tried loading aic7xxx_old but it did the same thing.  I get
the first piece of messages where it "downloads sequencer code" etc. It's
hanging just after that where it would normally start spitting out the
individual device info.

I moved the aic7xxx* modules in the xen0 module tree out of the way.  Now I can
get domain 0 to boot fine but have no CD Rom access.  I'll try running an insmod
of the module now that the machine is up.  Then I can copy-paste the error here.
Comment 2 Chris Evich 2005-07-01 09:25:33 EDT
Created attachment 116239 [details]
dmesg output

After moving the modules out of the way and getting Domain-0 to boot I strace
-ff -q -r -v -o /tmp/test insmod ./aic7xxx.ko.	Attached is the dmesg output
and the 'test' trace file though I don't know if it's very useful.
Comment 3 Chris Evich 2005-07-01 09:27:29 EDT
Created attachment 116240 [details]
strace output

did a kill -9 on the strace after letting it run for a while.
Comment 4 Stephen Tweedie 2006-02-24 15:43:25 EST
This is a really old kernel and I expect it is fixed with the new rawhide
kernels --- certainly I've not seen any such SCSI problems on recent FC5test
kernels.  Please reopen the bug if you can reproduce with FC5test3 or rawhide.

Note You need to log in before you can comment on or make changes to this bug.