Bug 162169 - Bad: Eclipse with CDT runs out of memory when building
Bad: Eclipse with CDT runs out of memory when building
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Overholt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-30 11:50 EDT by Trevor Davenport
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-05 16:42:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Testcase Project (7.85 KB, application/octet-stream)
2005-08-04 20:54 EDT, Trevor Davenport
no flags Details

  None (edit)
Description Trevor Davenport 2005-06-30 11:50:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050623 Fedora/1.0.4-5 Firefox/1.0.4

Description of problem:
When I use eclipse I get out of memory errors.  It says that I can increase the heap size with some command line arguements.  I haven't tried these.  But this used to not happen and does not when using the sun jvm, only with gcj.  It specifically happens when I use cdt and and have a c/c++ project that has multiple files and I rebuild.  A single files doesn't seem to cause the problem.  This problem only happens at the build stage.

Version-Release number of selected component (if applicable):
eclipse-cdt-3.0.0_fc-0.M6.8, eclipse-platform-3.1.0_fc-0.RC3.3

How reproducible:
Always

Steps to Reproduce:
1. Create a c/c++ project with lots of files (probably easier to import something)
2. Allow eclipse to build (either automatic or manual)
3. get error.
  

Actual Results:  I got my out of memory error I always get.

Expected Results:  No out of memory error and everything working.  

Additional info:

if launched in a terminal this is the output:

Reaped unknown child pid = 7223
Reaped unknown child pid = 7225
Unhandled event loop exception
Reason:
Failed to execute runnable (org.eclipse.jface.util.Assert$AssertionFailedException: null argument;)
Reaped unknown child pid = 7256
GC Warning: Repeated allocation of very large block (appr. size 89837568):
        May lead to memory leak and poor performance.
GC Warning: Out of Memory!  Returning NIL!
Unhandled event loop exception
Reason:
java.lang.OutOfMemoryError




An error also appears in one of the Debug/srcfile.d files which says:

warning: NUL character seen; rest of line ignored
Comment 1 Andrew Haley 2005-07-30 06:05:03 EDT
The problem with this bug report is that it isn't specific.

If we're to duplicate your problem, we need, for example, a public repository
that  you have tried and that generated an error.  Then, we can try the same
repository to see if it does the same for us.


Comment 2 Trevor Davenport 2005-08-04 20:52:27 EDT
Alright, I meant to get back to this quicker but couldn't.  I am still getting
this with rawhide as of august 4th.  I did some more investigating and I've
confirmed that it does not happen with sun java.  I'm also attatching a project
that causes the error.  I think the error must be related to how I have set the
project up ot use pkg-config.  I can't get the error if I don't set it up that
way.  The steps to produce the error are to open the project, build, launch,
then change the source (adding a space somewhere works well) and then
rebuilding.  When the rebuild happens it will not build and end with the
warning: NUL character seen; rest of line ignored and eat up some memory.  To
build again just clean the project and then you can repeat.  While this project
doesn't cause the out of memory error on the first rebuild I am pretty sure that
is just because of the size of the project.  If there is something specific i
can do to get more information I'd be happy to do it.  
Comment 3 Trevor Davenport 2005-08-04 20:54:03 EDT
Created attachment 117483 [details]
Testcase Project
Comment 4 Trevor Davenport 2005-10-28 20:18:20 EDT
This still happens for me with current Fedora Rawhide (October 28 2005).  It
doesn't happen if I use a standard make project.  Only a managed project.  When
I was creating managed projects I was addes pkg-config parameters by just adding
them to the miscelaneous areas in the build options.  After that it begins
eating memory pretty fast until it runs out.  
Comment 5 Andrew Overholt 2005-11-15 14:35:33 EST
Does this happen with the FC4 packages?
Comment 6 John Thacker 2006-05-05 16:42:45 EDT
Closing due to lack of response.

Note You need to log in before you can comment on or make changes to this bug.