Bug 162235 - xcscope.el not found by emacs/xemacs
xcscope.el not found by emacs/xemacs
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: cscope (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Neil Horman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-01 04:04 EDT by David Juran
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-06 08:05:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Juran 2005-07-01 04:04:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Red Hat/1.7.8-1.1.3.1

Description of problem:
xcscope.el is not located on a path identified by load-path and can therefore not be found by emacs/xemacs

Version-Release number of selected component (if applicable):
cscope-15.5-9.RHEL3

How reproducible:
Always

Steps to Reproduce:
1. add (require'xcscope) to ~/.emacs as outlined in tha man page for xcscope
2. note that cscope is still not available in emacs/xemacs
  

Additional info:
Comment 1 Frank Ch. Eigler 2005-07-04 11:01:28 EDT
Good point.  xcscope.el should be installed into /usr/share/emacs/site-lisp.
Comment 2 Neil Horman 2005-07-05 13:36:38 EDT
Actually, xcscope.el should be in /usr/share/emacs/site-lisp for emacs and in
/usr/share/xemacs/site-packages/lisp for xemacs, and it appears in both places
for me (as the result of the triggerin scripts in the spec file.  When I run
emacs or xemacs, adding the require line in the .emacs file works just fine for
me (I am able to access the cscope meta-commands in the buffer.  This kind of
smells like a bad .emacs->.xemacs conversion to me.  Or perhaps, your site
configuarion has changed the default load path to look for cscope is someplace
other than where it is installed?  You'd be able to tell by stracing the xemacs
start up.  If the xcscope.el file isn't getting found, we'll see where its
looking on that.
Comment 3 David Juran 2005-07-06 08:05:56 EDT
OK, I think I found the error now. 
Previously we had cscope from Fedora Extras installed. This package didn't
contain any triggers but had instead placed xscope.el in
/usr/share/emacs/site-lisp. Then when cscope got included in RHEL3, we ran
'up2date -u cscope' to update to the RHEL3 version of cscope. And here I guess
things happened in the wrong order so that the links were never made.

Note You need to log in before you can comment on or make changes to this bug.