Bug 162236 - System freezes up when running /etc/cron.daily/prelink
System freezes up when running /etc/cron.daily/prelink
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-01 04:49 EDT by Suraj Kurapati
Modified: 2015-01-04 17:20 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 19:32:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
prelink log-file (86.98 KB, text/plain)
2005-07-01 04:52 EDT, Suraj Kurapati
no flags Details
log file generated by '/etc/cron.daily/prelink' under kernel 2.6.12-1.1398_FC4 (84.20 KB, text/plain)
2005-07-17 15:39 EDT, Suraj Kurapati
no flags Details
log file generated by '/etc/cron.daily/prelink' under kernel 2.6.12-1.1398_FC4 (84.20 KB, text/plain)
2005-07-17 15:39 EDT, Suraj Kurapati
no flags Details

  None (edit)
Description Suraj Kurapati 2005-07-01 04:49:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
When /etc/cron.daily/prelink is run, my system freezes after about 4.5 minutes.

Version-Release number of selected component (if applicable):
prelink-0.3.4-3

How reproducible:
Always

Steps to Reproduce:
1. Log in as the super user (root) and execute '/etc/cron.daily/prelink'
2. Log in as a normal user in a different virtual terminal and execute 'top'

Actual Results:  This is what I observe:
* The CPU-fan begins spinning faster and makes more noise.
* The CPU load average increases from 0.02 to about 1.16 (observed in 'top').
* After approx. 4 minutes and 32 seconds, the system suddenly freezes: 
  * All textual and graphical output disappears from my monitor screen (monitor just shows a black screen).
  * The busy indicator on the chasis of my computer and my CD-ROM drive are fully lit (solid color, no blinking).
  * The power button on the chasis of my computer does not respond (even after pressing it down for one minute).
* The system remains in this frozen state until I physically remove the power cord connected to the chasis of my computer.

Expected Results:  * /etc/cron.daily/prelink should finish its job and terminate. 
* The system should not freeze.

Additional info:

I reformatted my hard drives and performed a fresh install of FC4. Then I executed 'yum -y update' and rebooted the machine before executing '/etc/cron.daily/prelink'.
Comment 1 Suraj Kurapati 2005-07-01 04:52:17 EDT
Created attachment 116227 [details]
prelink log-file

This is the log-file generated by '/etc/cron.daily/prelink' when it froze my
system.
Comment 2 Jakub Jelinek 2005-07-01 05:02:35 EDT
If a userland program, which only reads/writes files and does some computation,
freezes your box, then it is a kernel problem, not a bug in the application.
If prelink needs to re-prelink a lot of binaries/libraries (e.g. when it is
run for the first time or when glibc is updated), it is re-prelinking several
thousands of binaries and libraries, so it is expected that it consumes some
CPU time and takes some time (but it is running reniced +19, so shouldn't
disturb too much).
Comment 3 Suraj Kurapati 2005-07-01 11:07:35 EDT
I forgot to mention that when the freeze occurs, the CPU fan spins at a much
lower but constant rate and the hard drives continue to spin at constant rate.
Comment 4 Dave Jones 2005-07-15 17:15:38 EDT
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.
Comment 5 Suraj Kurapati 2005-07-17 15:39:30 EDT
Created attachment 116854 [details]
log file generated by '/etc/cron.daily/prelink' under kernel 2.6.12-1.1398_FC4

This is the log file generated by '/etc/cron.daily/prelink' under the new
kernel: 2.6.12-1.1398_FC4
Comment 6 Suraj Kurapati 2005-07-17 15:39:43 EDT
Created attachment 116855 [details]
log file generated by '/etc/cron.daily/prelink' under kernel 2.6.12-1.1398_FC4

This is the log file generated by '/etc/cron.daily/prelink' under the new
kernel: 2.6.12-1.1398_FC4
Comment 7 Suraj Kurapati 2005-07-17 15:45:41 EDT
Comment on attachment 116854 [details]
log file generated by '/etc/cron.daily/prelink' under kernel 2.6.12-1.1398_FC4

I have retested the problem under the new kernel 2.6.12-1.1398_FC4 and
unfortunately the problem still occurs.

Also, I am not having any booting or hardware detection problems.

Thanks.
Comment 8 Dave Jones 2005-09-30 02:25:33 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 9 Suraj Kurapati 2005-09-30 12:01:19 EDT
I have recently discovered that the problem lies within my actual computer
hardware. The freeze-up seems to occur whenever very CPU intensive programs are
run. I think my CPU overheats and becomes paralyzed, due to some temperature
control mechanism, and stays that way until it has cooled down enough. But, once
it resumes operation it is once again servicing that CPU intensive program and
overheats again---an infinite loop?

Also, I've experienced the same problem while running some SPECINT benchmarks in
Ubuntu Hoary and while running some 3-D games in Windows XP on the same machine.
So, it is reasonable to say that the problem is NOT with Fedora Core.

Thanks for your patience.

Note You need to log in before you can comment on or make changes to this bug.