Bug 162430 - kdvi does not render correctly with gcc4 - PATCH
Summary: kdvi does not render correctly with gcc4 - PATCH
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdegraphics   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
: 162439 162878 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-04 14:35 UTC by Sammy
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-04 15:15:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kdvi patch for gcc4 (779 bytes, patch)
2005-07-04 14:36 UTC, Sammy
no flags Details | Diff

Description Sammy 2005-07-04 14:35:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux; X11; en_US) KHTML/3.4.1 (like Gecko)

Description of problem:
I had submitted this bug to KDE development and it was identified as a gcc4 
issue and resolved by the attached patch. 
 
The symptom is that kdvi renders headings and some superscripts in equation 
mode incorrectly. The KDE bug is: 
 
                      http://bugs.kde.org/show_bug.cgi?id=107065 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. See the examples in the above bug report 
2. Using current kdvi 
3. 
   

Additional info:

Comment 1 Sammy 2005-07-04 14:36:47 UTC
Created attachment 116330 [details]
kdvi patch for gcc4

Comment 2 Ngo Than 2005-07-04 15:15:26 UTC
it's now included in kdegraphics-3.4.1-2. Many thanks for your report.

Comment 3 Ngo Than 2005-07-04 19:01:23 UTC
*** Bug 162439 has been marked as a duplicate of this bug. ***

Comment 4 Ngo Than 2005-07-11 10:57:05 UTC
*** Bug 162878 has been marked as a duplicate of this bug. ***

Comment 5 Leonid Zeitlin 2005-07-12 11:57:27 UTC
Thanks for the workaround. Perhaps a gcc bug should be filed? GCC should have 
compiled the original code (without the workaround) correctly.


Note You need to log in before you can comment on or make changes to this bug.