This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 162458 - hddtemp does not detect my drives sensor
hddtemp does not detect my drives sensor
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: hddtemp (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
: MoveUpstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-05 02:52 EDT by drago01
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 02:14:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description drago01 2005-07-05 02:52:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; de-DE; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I have a hitachi desktar 250GB SATA HDD wich have a winbond sensors (windows displays it).
But when I try to use hddtemp to see the temp I get:
/dev/sda: ATA HDS722525VLSA80:  known drive, but it doesn't have a temperature sensor.


Version-Release number of selected component (if applicable):
hddtemp-0.3-0.4.beta13.1

How reproducible:
Always

Steps to Reproduce:
1. try to see the temp of /dev/sda
2.
3.
  

Actual Results:  /dev/sda: ATA HDS722525VLSA80:  known drive, but it doesn't have a temperature sensor.

Expected Results:  temp should be displayed

Additional info:
Comment 1 Michael Schwendt 2005-07-05 08:09:19 EDT
Please attach the output of " smartctl -A /dev/sda " as superuser root.
Comment 2 Michael Schwendt 2005-07-05 08:28:29 EDT
Also interesting (since the database file lists the drive as having a sensor!):

hddtemp -b | grep HDS
hddtemp -D /dev/sda
Comment 3 drago01 2005-07-06 02:08:00 EDT
smartctl do does not support libata yet...
smartctl -a /dev/sda
smartctl version 5.33 [x86_64-redhat-linux-gnu] Copyright (C) 2002-4 Bruce
AllenHome page is http://smartmontools.sourceforge.net/

Device: ATA      HDS722525VLSA80  Version: V36O

SATA disks accessed via libata are not currently supported by
smartmontools. When libata is given an ATA pass-thru ioctl() then an
additional '-d libata' device type will be added to smartmontools.
-----------------------
hddtemp -b | grep HDS
HDS722516VLAT[28]0                                      |   194 | Hitachi
Deskstar 7K250 160GB 2/8MB cache
HDS722525VLAT80                                         |   194 | Hitachi
Deskstar 7K250 200/250GB, 7200RPM, 8MB, Parallel-ATA
HDS722512VLAT80                                         |   194 | Hitachi
Deskstar 7K250 80GB
HDS722540VLAT20                                         |   194 | Hitachi
Deskstar 7K250, 40GB, 7200RPM, 2MB cache
HDS722580VLAT20                                         |   194 | Deskstar 7K250
60GB
HDS728080PLAT20                                         |   194 | Hitachi
Deskstar 7K80 80GB
HDS722525VLSA80                                         |   194 | Hitachi
Deskstar 7K250 250GB, 7200RPM, 8MB, Serial-ATA
--------------------
hddtemp -D /dev/sda
================= hddtemp 0.3-beta13 ==================
Model: ATA HDS722525VLSA80


If one of the field value seems to match the temperature, be sure to read
the hddtemp man page before sending me a report (section REPORT). Thanks.
Comment 4 Michael Schwendt 2005-07-06 04:36:32 EDT
Okay. The output of "hddtemp -D /dev/sda" indicates that hddtemp is broken,
either on x86_64 or for SATA, since it doesn't display any registers and hence
doesn't read from register 194 either.
Comment 5 drago01 2005-07-06 06:16:20 EDT
fix?
should I report this upstream?
if yes where?
Comment 6 Ville Skyttä 2005-07-06 16:55:28 EDT
I have no x86_86 nor SATA devices to test with, so I can't really help much 
here.  Asking upstream wouldn't hurt; see end 
of /usr/share/doc/hddtemp-*/README for contact information. 
Comment 7 drago01 2005-07-07 02:10:06 EDT
ok
want to add that x86_64 isn't the problem.
hddtemp works on by IDE hardisks /dev/hda and /dev/hdb
so the problem is SATA (when using libata?)
Comment 8 Ville Skyttä 2006-02-26 12:48:15 EST
I believe this is fixed in the just-pushed 0.3-0.8.beta14.fc* and new FC4 update
kernels, at least things work with my SATA drive in Rawhide and it looks like
your drive is listed in the latest hddtemp.db.  I still don't have a FC4 SATA
system available though; could you verify if it works for you now?
Comment 9 drago01 2006-02-27 01:43:42 EST
yes it works since ata passthru is enabled in the kernel.
I have a new hardisk which shows this:
WARNING: Drive /dev/sdb doesn't appear in the database of supported drives
WARNING: But using a common value, it reports something.
WARNING: Note that the temperature shown could be wrong.
WARNING: See --help, --debug and --drivebase options.
WARNING: And don't forget you can add your drive to hddtemp.db
/dev/sdb: HDT722525DLA380:  25°C or °F
(25°C seems correct)
Comment 10 Ville Skyttä 2006-02-27 02:14:12 EST
Ok, closing because the original issue is fixed.  I suggest that you send the ID
and human readable name of your drive upstream (see
http://www.guzu.net/linux/hddtemp.php for the maintainer's address) so that it
will be included in future hddtemp.db revisions.

Note You need to log in before you can comment on or make changes to this bug.