This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 162466 - Missing LG 1710B entry in monitor data base leads to flawed X setup
Missing LG 1710B entry in monitor data base leads to flawed X setup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-05 05:08 EDT by Joachim Frieben
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 0.160-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-01 04:10:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
X configuration file produced by "system-config-display" (2.69 KB, text/plain)
2005-07-05 05:09 EDT, Joachim Frieben
no flags Details
L1710B inf file provided by the manufacturer LG (1.65 KB, text/plain)
2005-07-06 04:02 EDT, Joachim Frieben
no flags Details
Ananconda generated test X configuration file (3.48 KB, text/plain)
2005-10-06 04:52 EDT, Joachim Frieben
no flags Details
Anaconda generated test X configuration file (3.48 KB, text/plain)
2005-10-06 04:52 EDT, Joachim Frieben
no flags Details
X.0.log for LG1710B attached to IBM ThinkPad T23 (no DDC) (56.83 KB, text/plain)
2006-03-13 15:51 EST, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2005-07-05 05:08:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Epiphany/1.6.1

Description of problem:
After setting up X by means of "system-config-display", the image quality of an external LG 1710B monitor attached to the analog output (VGA) of an IBM Thinkpad T23 notebook turns out to be very bad. Checking the automatically generated "xorg.conf" file reveals that the vertical frequency is set to 75 Hz which is definitely too much for this flat panel display.

Version-Release number of selected component (if applicable):
hwdata-0.158.1-1

How reproducible:
Always

Steps to Reproduce:
1. Run "system-config-display".
  

Actual Results:  The image displayed on the LG 1710B flat panel monitor is fuzzy.

Expected Results:  Albeit using the analog VGA signal, the image should be crisp, ... well, at least crisper than it actually is.

Additional info:

The vertical frequency is set to 75 Hz in "xorg.conf" which is definitely too much for this flat panel display. After reducing the maximum vertical frequency to 60 Hz, the image quality is excellent. Checking "MonitorsDB" of the "hwdata" package, no entry for "L1710B" is found. It seems that DDC returns an incorrect value of 75 Hz for the maximum vertical frequency. It needs to be overridden by a suitable entry in "MonitorsDB". The annoying thing is that notebooks have the reputation of producing poor analog VGA signals. The average user might be tempted to attribute the poor image quality to this empirical fact and not even think of a problem related to the X configuration.
Comment 1 Joachim Frieben 2005-07-05 05:09:25 EDT
Created attachment 116346 [details]
X configuration file produced by "system-config-display"
Comment 2 Bill Nottingham 2005-07-05 10:05:22 EDT
Do you have an INF file for this monitor?
Comment 3 Joachim Frieben 2005-07-06 04:02:21 EDT
Created attachment 116399 [details]
L1710B inf file provided by the manufacturer LG
Comment 4 Bill Nottingham 2005-07-06 11:44:30 EDT
Added, will be in 0.160-1
Comment 5 Joachim Frieben 2005-07-06 14:10:55 EDT
Under Windows XP Professional, the (external) L1710B monitor is automatically
detected and configured as a plug and play monitor with a refresh rate of 60 Hz.
I have no idea why LG chose 75 Hz in their device file. In this respect, the inf
file content should of course not be adopted identically.
Comment 6 Bill Nottingham 2005-07-06 14:22:45 EDT
Changed to max out at 70, that should allow something sane to happen.
Comment 7 Joachim Frieben 2005-10-06 04:49:56 EDT
After a clean install from the Rawhide development tree, the default
refresh rate is still set to 75 Hz, as well for the graphical installer
as for the final X setup. On can use "Screen Resolution Preferences"
later on to switch to the lower of the two suggested values which is
60 Hz. The relevant package is "hwdata-0.169-1". The entries for the
L1710B display show the correct modified values:

>
> LG Electronics Inc.; LG L1710B(Digital); GSM4358; 30.0-71.0; 56.0-70.0
> LG Electronics Inc.; LG L1710B(Analog); GSM4356; 30.0-83.0; 56.0-70.0
>

but they don't get used. At 75 Hz the image is blurred, at 60 Hz the
image is crisp.

What is even more weird is that when I set the driver to "vesa", the only
suggested refresh rate by "Screen Resolution Preferences" is 76 Hz, but
nevertheless, the image is ok now!
Comment 8 Joachim Frieben 2005-10-06 04:52:29 EDT
Created attachment 119659 [details]
Ananconda generated test X configuration file
Comment 9 Joachim Frieben 2005-10-06 04:52:43 EDT
Created attachment 119660 [details]
Anaconda generated test X configuration file
Comment 10 Adam Jackson 2006-03-13 15:12:46 EST
can you attach the X startup log?  i wonder if we're just not getting anything
useful out of DDC.
Comment 11 Joachim Frieben 2006-03-13 15:51:00 EST
Created attachment 126069 [details]
X.0.log for LG1710B attached to IBM ThinkPad T23 (no DDC)
Comment 12 Joachim Frieben 2006-03-14 14:17:52 EST
I also tried with all relevant monitor entries being outcommented. The
relevant section of "X.0.log" now reads:

  (II) SAVAGE(0): Monitor0: Using default hsync range of 30.00-83.00 kHz
  (II) SAVAGE(0): Monitor0: Using default vrefresh range of 56.00-75.00 Hz
                                  ^^^^^^^

The only difference is the keyword "default" which indicates that the
frequency ranges have been returned by DDC. They are exactly identical to
the values gathered by "pyxf86config" (certainly also via DDC and not by
querying the hardware data base) during the system install.
Comment 13 Adam Jackson 2006-07-08 19:43:57 EDT
Looks like it's not properly setting the monitor sync range based on EDID info.
 This should be fixed as of about xorg-x11-server-1.1.0-17 in rawhide; can you test?
Comment 14 Joachim Frieben 2006-09-01 04:10:44 EDT
The issue was fully settled in "rawhide" a couple of days ago. Thanks
for the great work!

Note You need to log in before you can comment on or make changes to this bug.