This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 162505 - Bad: Can't connect to the network
Bad: Can't connect to the network
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-05 13:13 EDT by Antonio Trogu
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-12 14:25:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
sysreport output (283.47 KB, application/octet-stream)
2005-07-11 11:38 EDT, Antonio Trogu
no flags Details

  None (edit)
Description Antonio Trogu 2005-07-05 13:13:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050524 Firefox/1.0.4 (Ubuntu package 1.0.2 MFSA2005-44)

Description of problem:
PC type: HP Compaq DX2000 MT
Ethernet controller: Intel Corp. 82562EZ 10/100 Ethernet Controller (rev 02)
Network card is correctly detected, both during first installation and reinstalling. Mii-tool and ethtool work, and link is detected, but the connection doesn't work anyway. Tried with DHCP and manual config. Tried with any speed/duplex combination, even forcing it on the switch port. Tried with Intel driver too. No success at all. With Ubuntu Linux 5.0.4 installed in another partition the card works perfectly!

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install FC4 from CDs
2. Boot the PC
3. Try to connect to the network


Additional info:
Comment 1 Harald Hoyer 2005-07-06 12:01:48 EDT
what does
# /sbin/ifconfig
say?
please attach the /etc/sysconfig/network-scripts/ifcfg-* files
Comment 2 Antonio Trogu 2005-07-07 02:58:44 EDT
ifconfig:

eth0      Link encap:Ethernet  HWaddr 00:0F:FE:1B:65:F7
          inet addr:10.1.1.50  Bcast:10.1.255.255  Mask:255.255.0.0
          inet6 addr: fe80::20f:feff:fe1b:65f7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2998 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2998 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:3727738 (3.5 MiB)  TX bytes:3727738 (3.5 MiB)

---

ifcfg-eth0:

# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
IPV6INIT=no
ONBOOT=yes
USERCTL=no
PEERDNS=yes
TYPE=Ethernet
DEVICE=eth0
HWADDR=00:0f:fe:1b:65:f7
BOOTPROTO=none
NETMASK=255.255.0.0
IPADDR=10.1.1.50
GATEWAY=10.1.1.2

---

ifcfg-lo:

DEVICE=lo
IPADDR=127.0.0.1
NETMASK=255.0.0.0
NETWORK=127.0.0.0
# If you're having problems with gated making 127.0.0.0/8 a martian,
# you can change this to something else (255.255.255.255, for example)
BROADCAST=127.255.255.255
ONBOOT=yes
NAME=loopback
Comment 3 Amadeus W. M. 2005-07-07 03:59:01 EDT
Original poster configures the network card with dhcp from
system-config-network, and ifcfg-eth0 has the static IP settings. Possibly
related to bug 162648.
Comment 4 Antonio Trogu 2005-07-07 09:59:23 EDT
This is partially true, because in this case the default gateway is correctly set.
And even if I adjust manually the ifcfg-eth0 file, both for dhcp and manual
configuration, the network still doesn't work.
Comment 5 Harald Hoyer 2005-07-08 06:18:29 EDT
well, then it seems to be a kernel problem.
Comment 6 John W. Linville 2005-07-11 10:22:10 EDT
Have you tried booting w/ "acpi=off" on the kernel command line?  If not, 
please do so and post the results. 
 
Also, please attach the output of running "sysreport"...thanks! 
Comment 7 Antonio Trogu 2005-07-11 11:38:36 EDT
Created attachment 116607 [details]
sysreport output
Comment 8 Antonio Trogu 2005-07-11 11:42:25 EDT
Wonderful! acpi=off makes the network work!
I have posted the sysreport output.
Thanks John.

Antonio
Comment 9 John W. Linville 2005-07-11 11:57:24 EDT
Antonio, thanks for the quick turn-around!  
  
Unfortunately, success w/ "acpi=off" usually indicates a problem w/ the BIOS  
of your machine.  Often it is limited to IRQ routing, so you may want to try  
also w/ "acpi=noirq" to see if that work as well.  If so, you still should  
have most ACPI capabilities available. 
 
You may also want to check w/ your motherboard vendor to see if an updated 
BIOS is available. 
Comment 10 Antonio Trogu 2005-07-12 11:09:12 EDT
OK.
 - acpi=noirq -> same problem
 - upgraded kernel to 2.6.12-1.1390_FC4 -> same problem
 - upgraded motherboard BIOS -> same problem

At boot start - without 'acpi=off' - I read:
...
Uncompressing Linux... OK, booting the kernel.
Irq 9: nobody cared!
handlers: [<c022f8df>] (acpi_irq+0x0/0x14)
Disabling IRQ #9
...
Comment 11 John W. Linville 2005-07-12 14:25:05 EDT
Well, I'm sorry... :-(  Unfortunately, there isn't much I can do to improve 
things for you. 
 
Hopefully some later BIOS update will improve things for you -- you may want 
to contact your BIOS/motherboard vendor to encourage them to make sure they 
support Linux.  Otherwise, "acpi=off" will remain your best bet. 
 
Thanks again...I wish I could do more... 

Note You need to log in before you can comment on or make changes to this bug.