Bug 162530 - Hardware is not found or detected - Anaconda hangs on RH 9.0
Hardware is not found or detected - Anaconda hangs on RH 9.0
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
http://www.not-applicable.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-05 16:47 EDT by Andrew Khomski
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-06 11:43:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Khomski 2005-07-05 16:47:41 EDT
Description of problem:
When installing the RH 9.0 on the new HD (Seagate - 160 Gb), I have noticed 
the following.
After selecting (set by default) Graphical install and press Enter, Anaconda 
will start detecting all the devices and drivers. At some point of time if 
Anaconda fails to detect specific device it will just hang. It won't respond 
to Ctrl + Alt + F1 or Ctrl + Alt + F2 or Ctrl + Alt + F3 or Ctrl + Alt + F4 as 
well as to Ctrl + Alt + Del.

Attempt to restart - will bring the same result - Anaconda will hang.
Here is an TEXT of message displayed on the screen:
"hdb: 312581808: clusters (160042 Mb) w/8192Kib Cache, CHS = 19457/255/63, 
UDMA (100)
hdc: ATAPI 48x CD-ROM drive, 128 Kb cache
Uniform CD-Rom driver revision: 3.12
hdd: ATAPI 40xCDROM CD-R/RW drive, 8192Kb Cache
IDE-floppy driver 0.99.newide
Partition Check:
 hda: hda1 hda2
 hdb: unknown partition table
IDE-Floppy driver 0.99.newide
USB.C: Registered new driver usbdevfs
USB.C: Registered new driver hub
ehci-hcd 00:1d.7: PCI device 8086:24cd
ehci-hcd 00:1d.7: irq 9, pci mem e080d000
usb.c: new USB bus registered, assigned bus number 1
ehci-hcd 00:1d.7: enabled 64 bit PCI DMA
PCI: 00:1d.7: PCI cache line size set icorrectly (0 bytes) by BIOS / FW
PCI: 00:1d.7: PCI cache line size corrected to 16
ehci-hcd 00:1d.7: USB 2.0 enabled, EHCI 1.00, driver 2003-JAN-22
hub.c: USB hub found
hub.c: 6 ports detected
usb-uhci.c: $Revision: 1.275$ time 09:35:56 Feb-27-2003
usb-uhci.c: High bandwidth mode enabled
usb-uhci.c: USB UHCI at I/O 0xd800, IRQ 3
usb-uhci.c: Detected 2 ports".

Version-Release number of selected component (if applicable):
RH 9.0; Linux 2.4.20 kernel

How reproducible:
Every time.

Steps to Reproduce:
1.Setup CD Rom to be Boot # 1 drive (BIOS)
2.Insert CD # 1 for RD installation (I used RH 9.0; Linux 2.4.20 kernel)
3.Restart the computer.
4.Graphical install option is selected by default and user has an option to 
select <Enter>, press Enter.

Actual results:
1) Observe the message received (I mentioned this message in the "Description" 
section of this bug).
2) Wait and observe that Installation process is hanged.
Note: 
One can even try Ctrl + Alt + F1 or Ctrl + Alt + F2 or Ctrl + Alt + F3 or Ctrl 
+ Alt + F4 as well as to Ctrl + Alt + Del and find that there is no response 
from the system.

Expected results:
I'm new to Linux install and I'm very basic Linux user.
However I'd expect that if some of the Hardware / drivers are not detected 
properly by Linux, it shall skip them for later and continue with installation.
If it is an expected approach, I would strongly recommend changing it and 
modify this bug into Enhancement.

Additional info:
Well I actually found work around. Since I have analyzed a bit of situation, I 
thought I'll remove couple of my devices that perhaps causing RH Linux to hang 
during the install stage.
So I disconnected my web camera and second mouse (kids mouse - used by my son 
to play games:).
Restarted my PC and it started working with no issues...

My PC information:
==================
Dell PC with Windows XP SP 2 on 1st HD (WD) - 30 Gb
RAM 512 Mb
Second HD (purchased specifically for Linux install 160 Gb) - set as slave.
Comment 1 Suzanne Hillman 2005-07-06 11:43:38 EDT
This bug was entered against Red Hat 9, which has not been supported since April
30, 2004. For migration inforamtion, please see
http://www.redhat.com/solutions/business/migration/

Note You need to log in before you can comment on or make changes to this bug.