Bug 16254 - DDD and RH Beta 7
Summary: DDD and RH Beta 7
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: ddd   
(Show other bugs)
Version: 7.1
Hardware: i686 Linux
high
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-15 15:22 UTC by Travis Berthelot
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-18 22:53:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Red Hat Bugzilla 2000-08-15 15:22:31 UTC
I want to run DDD from a remote machine, but it gives me a segmentation fault.  It only works on the installed system.  I have tried to build the 
new 3.2.91 DDD that is supposed to fix Xclient problems, but it fails on PannedGE.C with the following error:

c++ -DHAVE_CONFIG_H -I. -I. -I. -I./.. -isystem /usr/X11R6/include    -DNDEBUG -O2 -g -W -Wall -trigraphs  -c PannedGE.C
PannedGE.C: In function `void __static_initialization_and_destruction_0 
(int, int)':
PannedGE.C:88: non-lvalue in unary `&'
make[1]: *** [PannedGE.o] Error 1
make[1]: Leaving directory `/usr/local/ddd-3.2.91/ddd'
make: *** [all-recursive] Error 1

I can get it to build if I replace portholeWidgetClass on line 90 with zero.  I have tried both openmotif and lesstif with the same results.
I have lesstif .91 4-1 and GCC 2.95

Thank you in advance for any help

Comment 1 Red Hat Bugzilla 2000-08-16 08:36:20 UTC
strange, i can't reproduce this problem. Please check,
that you have to install openmotif.

Comment 2 Red Hat Bugzilla 2000-08-16 12:54:57 UTC
As I have stated already I have tried it with openmotif.

Comment 3 Red Hat Bugzilla 2000-08-16 13:19:15 UTC
ddd works on remote machine with RC1, i don't see sigmention fault. I think,
this problem
was fixed in RC1. Please try to updated glibc, openmotif and ddd from current
rawhide.


Comment 4 Red Hat Bugzilla 2000-08-16 14:33:08 UTC
I installed the rawhide versions of glibc, ddd, and openmotif.  I obtained the same segmentation fault when I tried to run openmotif from a remote machine.

Comment 5 Red Hat Bugzilla 2000-08-16 15:18:00 UTC
I have found that ddd runs on a remote sun sparc machine running X, but doesn't work on Windows NT with Reflections.

Comment 6 Red Hat Bugzilla 2000-08-16 15:34:41 UTC
I have resolved the issue.  If you set the DISPLAY on Windows NT when using Reflections ddd will die with a segmentation fault.  Although if you clear 
the DISPLAY environment variable and set the DISPLAY using ddd's -display DISPLAY option it works perfectly.  It's still a bug, but easy to work around.

Comment 7 Red Hat Bugzilla 2000-09-18 22:53:40 UTC
Note: With RH 7.0 final, I get this same compile failure. I get it with motif,
and compiling ANY version of ddd -- including the one provided on 7.0's
powertools.

Is there a fix or work-around?

Comment 8 Red Hat Bugzilla 2000-12-04 11:25:11 UTC
It's fixed in 3.2.92. You will find it in rawhide later.


Note You need to log in before you can comment on or make changes to this bug.