Bug 162550 - broken Requires: libpixman-devel >= %{pixman_version}
broken Requires: libpixman-devel >= %{pixman_version}
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cairo (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-06 04:09 EDT by Michael Schwendt
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-06 10:49:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2005-07-06 04:09:13 EDT
Undefined RPM macro %{pixman_version} found in package dependencies:

$ rpm --query cairo-devel
cairo-devel-0.5.1-4

$ rpm --query --requires cairo-devel
cairo = 0.5.1-4
fontconfig-devel >= 2.0
freetype-devel >= 2.1.3-3
libpixman-devel >= %{pixman_version}
libpng-devel  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
xorg-x11-devel  

Solution: Either define pixman_version in the spec or delete this minimum version.
Comment 1 Kristian Høgsberg 2005-07-06 10:49:04 EDT
Michael,

Thanks for pointing this out.  I already define libpixman_version, which is what
this macro should have been. cairo-0.5.1-5 has the fix and should be in rawhide
soon.

Note You need to log in before you can comment on or make changes to this bug.