Bug 162652 - Current Stable Zope and Plone don't play nicely with current Python
Current Stable Zope and Plone don't play nicely with current Python
Product: Fedora
Classification: Fedora
Component: plone (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2005-07-07 05:49 EDT by Kyle Pointer
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.1rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-08-21 17:19:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Kyle Pointer 2005-07-07 05:49:17 EDT
The current version of Plone cannot use python 2.4 as it causes errors that
render plone useless. 
The current version of Zope ( in extras ) is setup to use any version of python
over 2.(something) ( can't remember ), but by any means, using the RPM screws up
plone, because of zope using python 2.4. 

Anyways, I would like to propose a seperate zope package specificly setup to be
compatable with the stable version of the plone package. 
Perhaps by changing the ./configure.... stanza in the zope.spec file, towhere it
uses --with-python=/usr/bin/python2.3 ( this might require making a python2.3
package.. :\ ). ( and python2.3-devel ) [ all for backwards compatability ]

I can fix it for my personal use, so its not that big of a deal to me, however I
thought I would mention it so no one else has to have any trouble with it. 

Other than that though, the packager has done a fine job. 

-- Kyle Pointer
Comment 1 Kyle Pointer 2005-07-07 06:03:41 EDT
hmm... my fix doesn't work... darn..
But anyways, if we can get both plone and zope to use the right python binary (
/usr/bin/python2.3 ) I know that will make it work. Currently, it seems that
plone ( or zope ) uses /usr/bin/python. I have tried relinking the python binary
with the correct version, and that makes it work fine. 
( eg. rm -f /usr/bin/python && ln -s /usr/bin/python2.3 /usr/bin/python ) 
But of course, that breaks just about every other thing on the systme. :S
Comment 2 Kyle Pointer 2005-07-07 06:09:13 EDT
I just figured this one out. 
In the /var/lib/zope/bin directory, the zopectl and runzope scripts both have
the PYTHON variable set to /usr/bin/python 

That variable should be changed to point to a version of python that will work
with plone. 

That would probably require a python2.3 ( and python2.3-devel ) rpm. 

I'd be glad to make any packages needed to help fix this issue. I'll just need
help getting anything else ( namely the zope rpm ) patched up to use the correct
version of python. 
Comment 3 Aurelien Bompard 2005-08-01 15:47:03 EDT
I don't think that maintaining a separate version of python in Extras is
something that can be done. Too many conflicts on the system will result of it.

Plone 2.1 should work with python 2.4 and zope 2.8, but it has not yet been
released. I'm tracking it for the plone RPM, and I've just updated it to 2.1rc1.
Hopefully the final version will be out soon.
Comment 4 Aurelien Bompard 2005-08-11 05:43:13 EDT
Just updated to 2.1rc2, it seems to work fine for me. Can you confirm ?
Comment 5 Kyle Pointer 2005-08-12 19:12:40 EDT
Works great here too. :-) 

Note You need to log in before you can comment on or make changes to this bug.