Bug 162673 - "Package does not match checksum" error if yum suspended and then resumed
Summary: "Package does not match checksum" error if yum suspended and then resumed
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-07 14:35 UTC by Robin Green
Modified: 2014-01-21 22:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-08 00:15:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robin Green 2005-07-07 14:35:58 UTC
Description of problem:
If I suspend yum with CTRL+Z and then later resume it, the TCP connection is
closed but yum does not notice that it has closed early, and tries to verify the
checksum and fails. So it starts downloading the file again from another mirror.

Version-Release number of selected component (if applicable):
yum-2.3.3-1

How reproducible:
Always

Steps to Reproduce:
1. Press CTRL+Z while yum is downloading an rpm
2. Wait a while
3. Type "fg" to resume yum
  
Actual results:
http://sunsite.mff.cuni.cz/pub/fedora/development/i386/Fedora/RPMS/openoffice.org-core-1.9.114-1.2.0.fc5.i386.rpm:
[Errno -1] Package does not match checksum
Trying other mirror.


Expected results:
yum should notice that the connection has closed early, before the file has been
fully transferred, and use HTTP resume.

Comment 1 Seth Vidal 2005-07-07 22:19:57 UTC
I think my best response here is, umm, don't do that.

Yum's using regets anyway so the download shouldn't be any larger.

Comment 2 Robin Green 2005-07-07 23:02:20 UTC
(In reply to comment #1)
> I think my best response here is, umm, don't do that.

Not everyone has an always-on internet connection; even those who have one, may
want to pause their downloads so as to give priority to another user of the
connection. Is there another way to suspend yum without incurring this problem?
 
> Yum's using regets anyway so the download shouldn't be any larger.

It actually restarts from the beginning, every time, so yes, the download does
take longer. That's the real issue here.

Comment 3 Seth Vidal 2005-07-07 23:18:02 UTC
are you sure it's restarting the whole download? it will show the whole progress
bar b/c yum is showing 100% download of the remaining parts but it doesn't
download the whole thing again.

Comment 4 Robin Green 2005-07-08 00:15:09 UTC
You're right, it doesn't start from the beginning. I was confused by the
progress display.

Which only leaves the error message, which is really NOTABUG because the package
indeed does not match the checksum. Marking NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.