Bug 16269 - Edit file from gmc using gedit doesn't work.
Summary: Edit file from gmc using gedit doesn't work.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mc   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-15 17:21 UTC by jbotha
Modified: 2013-04-02 04:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-17 23:03:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix bug when using editor not in a terminal window (392 bytes, text/plain)
2000-08-17 16:54 UTC, Tim Powers
no flags Details
Don't use the 1st patch I sent, use this one instead. (392 bytes, text/plain)
2000-08-17 19:32 UTC, Tim Powers
no flags Details

Description jbotha 2000-08-15 17:21:05 UTC
Select gEdit as the default editor in the gnome control center.
Now go to gmc, right click on a file and select Edit.
gEdit starts up, but does not load the file selected in gmc.

I am not sure if this is a gmc or gedit bug.  Selecting other editors works
correctly.

Comment 1 Tim Powers 2000-08-17 15:47:46 UTC
I am changing the component this belongs to (to mc) since the problem is not
isolated to just gedit. The problem exists with all editors which don't run in a
terminal. It appears that the filenames are not being fed to the editor unless
the option to run it from a terminal is selected.

Tim


Comment 2 Tim Powers 2000-08-17 16:52:18 UTC
I made a patch to fix the problem. Coming to a bugzilla near you.

Tim

Comment 3 Tim Powers 2000-08-17 16:54:22 UTC
Created attachment 2599 [details]
Patch to fix bug when using editor not in a terminal window

Comment 4 Tim Powers 2000-08-17 19:32:05 UTC
Created attachment 2616 [details]
Don't use the 1st patch I sent, use this one instead.

Comment 5 Tim Powers 2000-08-17 23:03:43 UTC
Ughh. New patch is in the package. Forgot to free quoted.

Tim

Comment 6 Tim Powers 2000-08-23 16:54:10 UTC
This is fixed in mc-4.5.51-18


Note You need to log in before you can comment on or make changes to this bug.