Bug 162752 - lockups with Athlon64 X2 and warm reboot
lockups with Athlon64 X2 and warm reboot
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-07-08 08:30 EDT by Noa Resare
Modified: 2015-01-04 17:20 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.12-1.1447_FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-09-05 05:03:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
dmesg (19.29 KB, text/plain)
2005-07-19 03:33 EDT, Noa Resare
no flags Details
lsmod (2.12 KB, text/plain)
2005-07-19 03:35 EDT, Noa Resare
no flags Details
lspci (1.56 KB, text/plain)
2005-07-19 03:36 EDT, Noa Resare
no flags Details

  None (edit)
Description Noa Resare 2005-07-08 08:30:07 EDT
Description of problem:

I experience hard lockups of my system with kernel-smp-2.6.12-1.1390_FC4 after
 a few minutes <10. kernel-smp-2.6.12-1.1387_FC4 has been running for a few
days without problems.

Version-Release number of selected component (if applicable):

How reproducible:
i've done it twice, both times after about 5 minutes.

Steps to Reproduce:
1. boot my system with kernel-smp-2.6.12-1.1390_FC4 from fc4 updates
2. login, check some email for a few minutes
Actual results:
hard lockup of the system. No mouse movement, doesn't answer to ping.

Expected results:

Additional info:

Motherboard: nForce4-based (Asus A8N-E, )
CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
Memory: 2GB Samsung (KVR400X64C3AK2/2G)

plenty of cooling, after having tried to get some reponse from the machine i
jumped into SETUP after reboot, and the reported processor temp was about 35C
Comment 1 Dave Jones 2005-07-08 19:03:31 EDT
can you try running memtest on this box for a while ?

also the output of dmesg, lsmod and lspci would be useful.
Comment 2 Dave Jones 2005-07-15 17:10:26 EDT
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak

Thank you.
Comment 3 Noa Resare 2005-07-19 03:32:11 EDT
sorry for the delay, I think now that I've found a pattern.

It doen't matter which one of the FC4 kernels I run, what does matter however is
if i reboot the machine cold or warm. Cold reboot gives a stable system. Warm
reboot locks up after a few minutes.
Comment 4 Noa Resare 2005-07-19 03:33:57 EDT
Created attachment 116912 [details]
Comment 5 Noa Resare 2005-07-19 03:35:14 EDT
Created attachment 116913 [details]
Comment 6 Noa Resare 2005-07-19 03:36:01 EDT
Created attachment 116914 [details]
Comment 7 Dave Jones 2005-08-26 04:40:39 EDT
try service stop cpuspeed, and see if stability improves.
If so, it's likely a bug that's fixed in the current kernel in updates-testing
Comment 8 Noa Resare 2005-08-31 10:51:26 EDT
Just back from a vacation i just tried to reproduce the lockup with
2.6.12-1.1447_FC4smp but it seems to have been fixed. Thanks! Closing this
tomorrow after a night of stress tests.

Note You need to log in before you can comment on or make changes to this bug.