Bug 162805 - fence_wti does not fence properly
fence_wti does not fence properly
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: fence (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-08 15:47 EDT by Josef Bacik
Modified: 2009-04-16 16:17 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2005-737
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-07 12:55:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sets default to reboot if no option specified. (1012 bytes, patch)
2005-07-08 16:10 EDT, Lon Hohberger
no flags Details | Diff

  None (edit)
Description Josef Bacik 2005-07-08 15:47:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Red Hat/1.0.4-1.4.1 Firefox/1.0.4

Description of problem:
When fencing a failed node on a cluster that is hooked up to a wti power switch, using fence_wti, you get the following messages in /var/log/messages

Jul  8 14:45:02 cluster1 fenced: agent "fence_wti" reports: failed: no operation specified
Jul  8 14:45:02 cluster1 fenced: fence "cluster2" failed

fence_wti requires -o option to work, and that isn't specified in the cluster.conf.

Version-Release number of selected component (if applicable):
fence-1.32.1-0

How reproducible:
Always

Steps to Reproduce:
1.fail one of the nodes
2.
3.
  

Actual Results:  node is not rebooted and fence fails.

Expected Results:  node should be fenced and rebooted.

Additional info:
Comment 1 Lon Hohberger 2005-07-08 15:56:57 EDT
"reboot" should be the default course of action for all fencing agents when -o
is not specified.  fence_wti doesn't honor this.
Comment 2 Lon Hohberger 2005-07-08 15:57:36 EDT
I touched the fence_wti.pl last, so this mine.
Comment 3 Lon Hohberger 2005-07-08 16:10:38 EDT
Created attachment 116535 [details]
Sets default to reboot if no option specified.
Comment 5 Red Hat Bugzilla 2005-10-07 12:55:51 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-737.html

Note You need to log in before you can comment on or make changes to this bug.