Bug 16281 - traceroute LSRR broken
traceroute LSRR broken
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: traceroute (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
:
: 17742 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-15 14:42 EDT by Ingo Luetkebohle
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-30 10:46:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Slightly modified from Alexis patch (URL for that one in text) (9.81 KB, patch)
2000-08-15 14:47 EDT, Ingo Luetkebohle
no flags Details | Diff

  None (edit)
Description Ingo Luetkebohle 2000-08-15 14:42:54 EDT
traceroute, as shipped with 6.2 (and earlier) does not support
Loose Source Record Route (LSRR) correctly. The result is:

--
[root@bombay traceroute-1.4a5]# /usr/sbin//traceroute -g 212.4.200.114
212.15.192.2
traceroute to  (212.15.192.2), 30 hops max, 46 byte packets
traceroute: sendto: Invalid argument
 46  	  ,    =-1ote ,9
--

The last line contains unprintable characters which sometimes render
the terminal broken.

A patch for the problem is available at 
	ftp://ftp.inr.ac.ru/ip-routing/lbl-tools/
It works, except that linux/types.h has to be included
before linux/icmp.h. Look and you'll see.
Comment 1 Ingo Luetkebohle 2000-08-15 14:47:47 EDT
Created attachment 2521 [details]
Slightly modified from Alexis patch (URL for that one in text)
Comment 2 Ingo Luetkebohle 2000-08-30 10:46:03 EDT
A new, supposedly combined patch for some problems traceroute has was posted
on the security-audit list:
	http://box3n.gumbynet.org/~fyre/traceroute-1.4a5-misc.patch

I didn't check it. Another recommandation from the same thread was to
use traceroute-nanog instead/additionally. The stock version of that
one exhibits the same -g problem as the stock traceroute, though.
Comment 3 Jeff Johnson 2000-10-04 15:20:29 EDT
FIxed (by adding modified patch) in traceroute-1.4a5-24. Thanks for the
pointers.
Comment 4 Jeff Johnson 2000-10-04 15:21:20 EDT
*** Bug 17742 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.