Bug 162838 - From bootup the PS2 mouse is non-functional
From bootup the PS2 mouse is non-functional
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-10 02:06 EDT by Aaron Schlaegel
Modified: 2015-01-04 17:20 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.14-1.1637_FC4smp
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-31 14:46:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (12.10 KB, text/plain)
2005-07-10 02:11 EDT, Aaron Schlaegel
no flags Details
messages (19.67 KB, text/plain)
2005-07-10 02:12 EDT, Aaron Schlaegel
no flags Details
Xorg.0.log (49.03 KB, text/plain)
2005-07-10 02:16 EDT, Aaron Schlaegel
no flags Details
output of dmesg (58.54 KB, text/plain)
2012-08-31 16:11 EDT, Peter H. Jones
no flags Details
output of lscpi command (8.14 KB, text/plain)
2012-08-31 16:12 EDT, Peter H. Jones
no flags Details
contents of /var/log/messages (2.49 MB, text/plain)
2012-08-31 16:14 EDT, Peter H. Jones
no flags Details

  None (edit)
Description Aaron Schlaegel 2005-07-10 02:06:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
The mouse is found and loaded in both the VTs and X, but nothing will get it to budge. When I look at the logs nothing seems awry.
A simple `shutdown -r now` will take care of the problem.

The exact same hardware worked flawlessly in FC3 and in Windows for over a year.

Version-Release number of selected component (if applicable):
all FC4 kernels through kernel-smp-2.6.12-1.1390_FC4.i686

How reproducible:
Sometimes

Steps to Reproduce:
1. Boot the system.
2. Try and move the mouse.


Actual Results:  The mouse loads, but fails to respond when moved in both VTs and X. 

Expected Results:  The cursor should move.

Additional info:

This is an infrequent bug, but comes up enough to be annoying. When it does come up, the mouse starts off not working. The mouse never stops working once the system is up.

The only way to get the mouse to work is to restart the system.

The only indication that the mouse is not working is that the cursor does not move. I can not find any error message in the logs.
Comment 1 Aaron Schlaegel 2005-07-10 02:11:16 EDT
Created attachment 116560 [details]
dmesg
Comment 2 Aaron Schlaegel 2005-07-10 02:12:33 EDT
Created attachment 116561 [details]
messages
Comment 3 Aaron Schlaegel 2005-07-10 02:16:36 EDT
Created attachment 116562 [details]
Xorg.0.log
Comment 4 Dave Jones 2005-07-15 17:49:11 EDT
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.
Comment 5 Aaron Schlaegel 2005-07-19 11:11:32 EDT
I am up to date with yum and still intermittently get the same problem.

`uname -r`:
> 2.6.12-1.1398_FC4smp

I forgot to mention that it is a PS2 mouse.

Since it either works from the start or is broken from the start I guess that it
is some kind of initialization issue. That is also supported by the fact that
all I have to do to get the mouse working is `shutdown -r now`, and the fact
that the same hardware worked on FC3 and Windows.
Comment 6 Aaron Schlaegel 2005-07-19 11:27:53 EDT
This is a clean install of FC4, with no hand-edits of /etc/sysconfig/hwconf or
/etc/modprobe.conf.

(I prefer to fresh install and just keep my /home partition.)
Comment 7 Aaron Schlaegel 2005-09-08 18:19:36 EDT
This bug is still present in the most recently released FC4 kernel.

`uname -r`
> 2.6.12-1.1447_FC4smp

PS. I made the Bug Summary more descriptive of the actual problem.
Comment 8 Ed 2005-09-27 19:44:33 EDT
I have the same problem. I had the mouse problem initially when I updated the
kernel. But somehow a reboot solved the problem. However, I just updated the
kernel to the latest 2.6.12-1.1456_FC4 and the mouse completely stopped working.
The mouse is a wireless USB mouse that is plugged into a ps2 adaptor.
Comment 9 Aaron Schlaegel 2005-09-28 02:10:02 EDT
Unfortunately 2.6.12-1.1456 also made my problem a lot worse.
Now I sometimes have to boot the system four times before the mouse will work.
I have also now seen the mouse start working, then after moving 1 inch die.

I changed the severity to High since the problem now happens on most boots.
Comment 10 Dave Jones 2005-09-30 03:21:41 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 11 Aaron Schlaegel 2005-10-01 13:01:44 EDT
`uname -r`:
> 2.6.13-1.1526_FC4smp

I was hopeful, but alas, on the second boot the mouse was unresponsive.
Comment 12 Dave Jones 2005-11-10 16:56:05 EST
Mass update to all FC4 bugs:

An update has been released (2.6.14-1.1637_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.

Comment 13 Aaron Schlaegel 2005-11-26 19:25:59 EST
`uname -r`
>2.6.14-1.1637_FC4smp

Still here. I noticed from the fedora list that others have similar problems
when they use kvm switches, but this is without a kvm switch.

I am willing to test or send logs if it will help. Currently I don't reboot very
often to avoid the bug, but this is far from ideal.

My power bill (and wife) will be happier when this is fixed.
Comment 14 Aaron Schlaegel 2005-12-31 14:46:27 EST
`uname -r`
>2.6.14-1.1653_FC4smp

The mouse now works! I am not sure if the new kernel or some other package fixed
the bug, but since the bug never got any attention I will remain happy that it
is gone.

Thanks to all the unknown soul who fixed the problem.

PS. I hope I set the status correctly.
Comment 15 Peter H. Jones 2012-08-31 16:11:49 EDT
Created attachment 608684 [details]
output of dmesg
Comment 16 Peter H. Jones 2012-08-31 16:12:49 EDT
Created attachment 608685 [details]
output of lscpi command
Comment 17 Peter H. Jones 2012-08-31 16:14:03 EDT
Created attachment 608687 [details]
contents of /var/log/messages

Note You need to log in before you can comment on or make changes to this bug.