Bug 162885 - svn requires libcom_err.so.3 (not provided as dependency)
svn requires libcom_err.so.3 (not provided as dependency)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: subversion (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-11 05:00 EDT by Bastien Miras
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-18 17:21:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Miras 2005-07-11 05:00:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
The svn binary provided by the FC3 package subversion-1.1.4-1.1.i386.rpm seems to have been linked with libcom_err.so.3.
# ldd /usr/bin/svn
...
libcom_err.so.3 => not found
...

 This library doesn't come with the dependencies. I was not able to find libcom_err.so.3 in the whole FC3 archive.

Version-Release number of selected component (if applicable):
subversion-1.1.4-1.1.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1. Download libcom_err.so.3 at http://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/i386/subversion-1.1.4-1.1.i386.rpm
2. install the rpm: 
# rpm -i subversion-1.1.4-1.1.i386.rpm
3. check needed libraries:
#  ldd /usr/bin/svn
  

Actual Results:  I get:
 libcom_err.so.3 => not found 

Expected Results:  I expect:
 libcom_err.so.3 => /usr/lib/libcom_err.so.3 

Additional info:
Comment 1 Joe Orton 2005-07-18 17:21:41 EDT
You probably have third-party or outdated packages (perhaps apr, apr-util) on
your system.  Try a complete "yum update".
Comment 2 Bastien Miras 2005-07-19 04:00:49 EDT
(In reply to comment #1)
> You probably have third-party or outdated packages (perhaps apr, apr-util) on
> your system.  Try a complete "yum update".

My system is up to date I have done:
yum update with no changes.

My version are:
apr-0.9.4-24.2
apr-util-0.9.4-17
It seems to be the last versions.

This doesn't explain to me in which package libcom_err.so.3 is since it is
needed by subversion-1.1.4-1.1.i386.rpm
For me the bug is still open.
Comment 3 Bastien Miras 2005-07-19 04:28:39 EDT
(In reply to comment #1)
> You probably have third-party or outdated packages (perhaps apr, apr-util) on
> your system.  Try a complete "yum update".

Ok I have check my system, I used third party library that's why I got the problem,
The problem is my side
thank you for you answer.

Note You need to log in before you can comment on or make changes to this bug.