Bug 16292 - Many shared libraries are missing from lib
Many shared libraries are missing from lib
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anonftp (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
: 16305 16385 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-15 16:38 EDT by Red Hat Bugzilla
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-16 17:23:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Red Hat Bugzilla 2000-08-15 16:38:27 EDT
libtermcap.so, librt.so and libpthread.so are missing from lib. You cannot
run ls with anonymous ftp. Please check you can run all binaries in bin
when loggin in via anonymous ftp.


H.J.
Comment 1 Red Hat Bugzilla 2000-08-15 16:51:37 EDT
Hm, works well for me. Confirmed, this is an "everything" install. So maybe some
missing dependency?


Comment 2 Red Hat Bugzilla 2000-08-15 16:57:58 EDT
# rpm -ql anonftp-3.0-6
/var/ftp
/var/ftp/bin
/var/ftp/bin/compress
/var/ftp/bin/cpio
/var/ftp/bin/gzip
/var/ftp/bin/ls
/var/ftp/bin/tar
/var/ftp/bin/zcat
/var/ftp/etc
/var/ftp/etc/group
/var/ftp/etc/ld.so.cache
/var/ftp/etc/passwd
/var/ftp/lib
/var/ftp/lib/ld-2.1.91.so
/var/ftp/lib/ld-linux.so.2
/var/ftp/lib/libc-2.1.91.so
/var/ftp/lib/libc.so.6
/var/ftp/lib/libnsl-2.1.91.so
/var/ftp/lib/libnsl.so.1
/var/ftp/lib/libnss_files-2.1.91.so
/var/ftp/lib/libnss_files.so.2
/var/ftp/pub

You can tell many shared libraries I mentioned are missing.
Comment 3 Red Hat Bugzilla 2000-08-16 06:33:53 EDT
Duplicated. These libraries are indeed now needed in the /var/ftp area. If you
upgrade it appears to work because you use the old /home/ftp area...

Anonymous ftp is indeed broken.
Comment 4 Red Hat Bugzilla 2000-08-16 11:11:56 EDT
Looks like it's a bug on upgrades only.  Does running "usermod -d /var/ftp ftp"
fix the problem?
Comment 5 Red Hat Bugzilla 2000-08-16 12:33:44 EDT
Let me make it clear. MANY SHARED LIBRARIES ARE MISSING FROM /var/ftp/lib.
Is that so hard to verify? It happens to me on both upgrade and install.

H.J.
Comment 6 Red Hat Bugzilla 2000-08-16 13:17:02 EDT
bero, fix this PLEASE>
Comment 7 Red Hat Bugzilla 2000-08-16 13:19:24 EDT
*** Bug 16305 has been marked as a duplicate of this bug. ***
Comment 8 Red Hat Bugzilla 2000-08-16 15:59:07 EDT
*** Bug 16385 has been marked as a duplicate of this bug. ***
Comment 9 Red Hat Bugzilla 2000-08-16 16:39:45 EDT
Does the anonftp-3.0-8 package in http://people.redhat.com/nalin/test/ fix
this?  On-the-fly tarring, compressing and gzipping appears to work with it.
Comment 10 Red Hat Bugzilla 2000-08-16 17:23:35 EDT
anonftp-3.0-8 seems ok.

Thanks.

H.J.
Comment 11 Red Hat Bugzilla 2000-08-16 17:28:41 EDT
Marking as fixed.

Note You need to log in before you can comment on or make changes to this bug.